ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmytro Sen" <d...@hortonworks.com>
Subject Re: Review Request 24650: Ambari should work with python 2.7 installed
Date Wed, 13 Aug 2014 14:52:42 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/24650/#review50458
-----------------------------------------------------------

Ship it!


Ship It!

- Dmytro Sen


On Aug. 13, 2014, 2:49 p.m., Andrew Onischuk wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/24650/
> -----------------------------------------------------------
> 
> (Updated Aug. 13, 2014, 2:49 p.m.)
> 
> 
> Review request for Ambari and Dmytro Sen.
> 
> 
> Bugs: AMBARI-6845
>     https://issues.apache.org/jira/browse/AMBARI-6845
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> RHEL7 included python 2.7 by default and if you attempt to install Ambari, it
> fails due to a dependency.
> 
>     
>     
>     
>     Error: Package: ambari-server-1.7.0-88.noarch (AMBARI.1.7.0-trunk-1.x)
>                Requires: python(abi) = 2.6
>                Installed: python-2.7.5-16.el7.x86_64 (@anaconda/7.0)
>                    python(abi) = 2.7
>                    python(abi) = 2.7
>      You could try using --skip-broken to work around the problem
>      You could try running: rpm -Va --nofiles --nodigest
>     
> 
> Check yum deplist ambari-server, looks like we say >= 2.6 for python but there
> is another python package that is = 2.6...
> 
>     
>     
>     
>     package: ambari-server.noarch 1.7.0-88
>       dependency: /bin/sh
>        provider: bash.x86_64 4.2.45-5.el7
>       dependency: openssl
>        provider: openssl.x86_64 1:1.0.1e-34.el7_0.3
>       dependency: postgresql-server >= 8.1
>        provider: postgresql-server.x86_64 9.2.7-1.el7
>       dependency: python >= 2.6
>        provider: python.x86_64 2.7.5-16.el7
>       dependency: python(abi) = 2.6
>        Unsatisfied dependency
>     
> 
> 
> Diffs
> -----
> 
>   ambari-server/pom.xml 1914c03 
> 
> Diff: https://reviews.apache.org/r/24650/diff/
> 
> 
> Testing
> -------
> 
> mvn clean test
> 
> 
> Thanks,
> 
> Andrew Onischuk
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message