ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10154) Hive Ambari install is missing a limits.d/hive
Date Mon, 23 Mar 2015 13:34:10 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10154?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14375890#comment-14375890
] 

Hudson commented on AMBARI-10154:
---------------------------------

ABORTED: Integrated in Ambari-trunk-Commit #2090 (See [https://builds.apache.org/job/Ambari-trunk-Commit/2090/])
AMBARI-10154. Hive Ambari install is missing a limits.d/hive (aonishuk) (aonishuk: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=8a24c720270e973ce4d7a17573699b6a9d4d8224)
* ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/params.py
* ambari-server/src/test/python/stacks/2.0.6/HIVE/test_hive_metastore.py
* ambari-server/src/test/python/stacks/2.1/HIVE/test_hive_metastore.py
* ambari-server/src/test/python/stacks/2.0.6/HIVE/test_hive_client.py
* ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/hive.py
* ambari-server/src/test/python/stacks/2.0.6/HIVE/test_hive_server.py
* ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/templates/hive.conf.j2


> Hive Ambari install is missing a limits.d/hive
> ----------------------------------------------
>
>                 Key: AMBARI-10154
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10154
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.1.0
>
>
> Ambari installs are missing the the Linux configuration files for the open-
> files/max-processes for HiveServer2.
> In comparison HDFS ships such a required file
> /etc/security/limits.d/hdfs.conf
> which contains the ulimit exceptions for nofile/nproc variables (similar to
> the ones listed in this doc item)
> <https://ambari.apache.org/1.2.0/installing-hadoop-using-ambari/content
> /ambari-chap5-3-1.html>
> An equivalent /etc/security/limits.d/hive.conf is required for HiveServer2 to
> avoid similar issues.
> This is a purely installed issue, with no corresponding Hive changes in
> Apache.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message