ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmytro Sen" <d...@hortonworks.com>
Subject Re: Review Request 39856: Oozie service have required, empty configs:oozie.authentication.kerberos.name.rules (after upgrade from 2.1.1 to 2.1.2.1)
Date Mon, 02 Nov 2015 17:22:40 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/39856/
-----------------------------------------------------------

(Updated Ноя. 2, 2015, 5:22 п.п.)


Review request for Ambari, Dmitro Lisnichenko, Sumit Gupta, and Vitalyi Brodetskyi.


Bugs: AMBARI-13629
    https://issues.apache.org/jira/browse/AMBARI-13629


Repository: ambari


Description
-------

STR: 
1)Deploy old version (2.1.1)
2)Make Ambari Only Upgrade to 2.1.2.1
3)Check oozie configs
Actual results:
Oozie service have required, empty configs:oozie.authentication.kerberos.name.rules


Diffs
-----

  ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog2121.java be88597

  ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog2121Test.java
3bef3a3 

Diff: https://reviews.apache.org/r/39856/diff/


Testing (updated)
-------

Unit tests passed

Manual testing done:
1. Upgrade 2.1.1 -> 2.1.2.1
2. Check oozie.authentication.kerberos.name.rules was removed
3. Check that oozie restarted successfully, service check passed
4. Enable security, check oozie.authentication.kerberos.name.rules was added. everything started
successfully


Thanks,

Dmytro Sen


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message