ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bhuvnesh Chaudhary <bchaudh...@pivotal.io>
Subject Adding repo in repoinfo.xml
Date Wed, 15 Jun 2016 00:16:43 GMT
Hi,

I am trying to add a repo in repoinfo.xml on Ambari 2.4, however it does
not show up on UI during install cluster wizard page.

I believe with Ambari 2.2, if a repo exists exists in repoinfo.xml, it will
show up on UI during Install Wizard page where stack version is selected.
However with Ambari 2.4, it is not showing up the repo on UI.

Example: HDP/2.5/repos/repoinfo.xml
If from the below repoinfo.xml i remove the latest tag, it shows the HDB
repo on UI during fresh install wizard, otherwise it just shows HDP and
HDP-UTILS repo.

<reposinfo>
  <latest>http://s3.amazonaws.com/dev.hortonworks.com/HDP/hdp_urlinfo.json
</latest>
  <os family="redhat6">
    <repo>
      <baseurl>
http://s3.amazonaws.com/dev.hortonworks.com/HDP/centos6/2.x/updates/2.5.0.0
</baseurl>
      <repoid>HDP-2.5</repoid>
      <reponame>HDP</reponame>
    </repo>
    <repo>
      <baseurl>
http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.21/repos/centos6
</baseurl>
      <repoid>HDP-UTILS-1.1.0.21</repoid>
      <reponame>HDP-UTILS</reponame>
    </repo>
*    <repo>*
*      <baseurl>http://c6401.ambari.apache.org/HDB
<http://c6401.ambari.apache.org/HDB></baseurl>*
*      <repoid>HDB</repoid>*
*      <reponame>HDB</reponame>*
*    </repo>*
  </os>
</reposinfo>

Thanks,
Bhuvnesh Chaudhary
Email: bchau <bchaudhary@gopivotal.com>dhary@pivotal.io
Desk: +1-650-846-1696 | Mobile: +1-973-906-6976

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message