apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 53629] Error building APR-iconv for x64
Date Mon, 08 Oct 2012 01:54:44 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53629

Gregg L. Smith <gls@gknw.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO

--- Comment #1 from Gregg L. Smith <gls@gknw.net> ---
After going through the hoops of picking out just what is changing in your
patch, here is what I found:

--- modules.mk.mak    2012-10-07 17:25:50.904000000 -0700
+++ modules.mk.mak    2012-10-07 17:22:12.453000000 -0700
@@ -167,10 +167,10 @@

 !IF "$(BIND_MODE)" == "shared"
 API_LIBS = $(APR_SOURCE)\x64\Debug\libapr-1.lib \
-       $(API_SOURCE)\x64\Debug\libapriconv-1.lib
+       $(API_SOURCE)\Debug\libapriconv-1.lib
 CFG_CFLAGS  = /MDd /Zi /Od /EHsc /D "_DEBUG"
 CFG_LDFLAGS = /debug /incremental:no /machine:X64
-CFG_OUTPUT  = x64\Debug\iconv
+CFG_OUTPUT  = Debug\iconv

 !ELSEIF "$(BIND_MODE)" == "static"
 APR_LIB = $(APR_SOURCE)\x64\LibD\apr-1.lib \

Without any more info than it breaks the VC++ compile I could not get behind
this change. I build x64 often and do not have a problem with this. 

If this is breaking your build, how come APR is not since it is output to
\x64\Debug also?

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message