apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 62188] Link error for support/ab when --with-openssl is not base OpenSSL
Date Sun, 18 Mar 2018 16:03:42 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=62188

Bernard Spil <brnrd@freebsd.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
          Component|support                     |APR-util
            Version|2.5-HEAD                    |1.6.3
            Product|Apache httpd-2              |APR
           Assignee|bugs@httpd.apache.org       |bugs@apr.apache.org

--- Comment #9 from Bernard Spil <brnrd@freebsd.org> ---
So I've solved this on one of the configs, the other one still fails. In
Apache's make output I can see

> configure: Configuring Apache Portable Runtime Utility library...
> configure: 
> checking for APR-util... yes
>  adding "-L/usr/lib" to LDFLAGS

Configure+build logs of apr+apr-util and apache here
https://keg.brnrd.eu/data/111amd64-default-local/2018-03-18_15h44m04s/logs/errors/apache24-2.4.33.log
https://keg.brnrd.eu/data/111amd64-default-local/2018-03-18_15h44m04s/logs/apr-1.6.3.1.6.1.log

The APR-util this built provides the following output

> # apu-1-config --includedir
> /usr/local/include/apr-1
> # apu-1-config --ldflags
>  -L/usr/local/lib -L/usr/lib
> # apu-1-config --libs
>      -lexpat
> # apu-1-config --link-ld
>  -L/usr/local/lib -laprutil-1
> # apu-1-config --link-libtool
>  -L/usr/local/lib -R/usr/local/lib -laprutil-1

Even though the libraries that were built do not depend on any library in
/usr/lib

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message