aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alasdair Nottingham <...@apache.org>
Subject Re: jmx-itests failing on IBM JDK
Date Wed, 30 Dec 2009 19:22:55 GMT
Hi,

Any idea how long it will take?

Thanks
Alasdair

2009/12/30 Jarek Gawor <jgawor@gmail.com>:
> Yes. I'll take care of it. I've seen and fixed this problem before for
> blueprint.
>
> Jarek
>
> On Wed, Dec 30, 2009 at 12:55 PM, Alasdair Nottingham <not@apache.org> wrote:
>> Hi,
>>
>> I'm sorry to report I have hit another problem with the jmx-itests. I
>> have managed to get them to run on my mac, but when I run them on a
>> linux machine using an IBM JDK I get the following error:
>>
>> java.lang.TypeNotPresentException: Type
>> org.ops4j.pax.exam.junit.Configuration not present
>>        at com.ibm.oti.reflect.AnnotationHelper.getAnnotation(AnnotationHelper.java:38)
>>        at com.ibm.oti.reflect.AnnotationHelper.getDeclaredAnnotations(AnnotationHelper.java:50)
>>        at com.ibm.oti.reflect.Method.getDeclaredAnnotations(Method.java:31)
>>        at java.lang.reflect.Method.getDeclaredAnnotations(Method.java:687)
>>        at java.lang.reflect.AccessibleObject.getAnnotations(AccessibleObject.java:186)
>>        at com.ibm.oti.reflect.Method.getAnnotation(Method.java:20)
>>        at java.lang.reflect.Method.getAnnotation(Method.java:677)
>>        at org.ops4j.pax.exam.junit.extender.impl.internal.CallableTestMethodImpl.getAnnotatedMethods(CallableTestMethodImpl.java:295)
>>        at org.ops4j.pax.exam.junit.extender.impl.internal.CallableTestMethodImpl.runBefores(CallableTestMethodImpl.java:162)
>>        at org.ops4j.pax.exam.junit.extender.impl.internal.CallableTestMethodImpl.injectContextAndInvoke(CallableTestMethodImpl.java:124)
>>        at org.ops4j.pax.exam.junit.extender.impl.internal.CallableTestMethodImpl.call(CallableTestMethodImpl.java:101)
>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
>>        at java.lang.reflect.Method.invoke(Method.java:599)
>>        at org.ops4j.pax.exam.rbc.internal.RemoteBundleContextImpl.remoteCall(RemoteBundleContextImpl.java:80)
>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
>>        at java.lang.reflect.Method.invoke(Method.java:599)
>>        at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:310)
>>        at sun.rmi.transport.Transport$1.run(Transport.java:171)
>>        at java.security.AccessController.doPrivileged(AccessController.java:284)
>>        at sun.rmi.transport.Transport.serviceCall(Transport.java:167)
>>        at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:547)
>>        at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:802)
>>        at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:661)
>>        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:896)
>>        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
>>        at java.lang.Thread.run(Thread.java:735)
>> Caused by: java.lang.ClassNotFoundException:
>> org.ops4j.pax.exam.junit.Configuration
>>        at java.lang.Class.forName(Class.java:169)
>>        at com.ibm.oti.reflect.AnnotationHelper.getAnnotation(AnnotationHelper.java:33)
>>        ... 29 more
>>
>> I've checked and I cannot see why this class cannot be found. It is
>> referenced in the pom, so I think it should be there.
>>
>> The JDK fullversion is:
>>
>> java full version "JRE 1.6.0 IBM Linux build pxi3260sr4-20090219_01 (SR4) "
>>
>> The JDK version is:
>> java version "1.6.0"
>> Java(TM) SE Runtime Environment (build pxi3260sr4-20090219_01(SR4))
>> IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 Linux x86-32
>> jvmxi3260-20090215_29883 (JIT enabled, AOT enabled)
>> J9VM - 20090215_029883_lHdSMr
>> JIT  - r9_20090213_2028
>> GC   - 20090213_AA)
>> JCL  - 20090218_01
>>
>> Does anyone know what the problem might be?
>> Thanks
>> Alasdair
>>
>> --
>> Alasdair Nottingham
>> not@apache.org
>>
>



-- 
Alasdair Nottingham
not@apache.org

Mime
View raw message