aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alasdair Nottingham (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARIES-708) org.apache.aries.util pom should point to java6-parent, not java5-parent
Date Tue, 12 Jul 2011 14:17:00 GMT

    [ https://issues.apache.org/jira/browse/ARIES-708?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13063925#comment-13063925
] 

Alasdair Nottingham commented on ARIES-708:
-------------------------------------------

Based on Valentin's comment I think we have this situation where you can't build aries with
a Java 5 SDK because too much needs Java 6, but some things we want to run on Java 5. Right
now we get into this kind of problem where @Overrides are added which work, because you use
the Java 6 compiler, but break those who enforce the Java 5 rules (mainly m2e). 

If we changed the Java 5 parent so it accepted Java 6 source, but kept everything else the
same I would hope it would ensure compatibility with Java 5 JVMs (even when compiling using
Java 6) but also allow @Override.

Thoughts?

> org.apache.aries.util pom should point to java6-parent, not java5-parent
> ------------------------------------------------------------------------
>
>                 Key: ARIES-708
>                 URL: https://issues.apache.org/jira/browse/ARIES-708
>             Project: Aries
>          Issue Type: Bug
>          Components: Util
>    Affects Versions: 0.4
>            Reporter: John Ross
>            Assignee: John Ross
>             Fix For: 0.4
>
>
> Pulled in org.apache.aries.util using m2e and received a bunch of errors about the @Override
annotation use on implemented interface methods. Parent should be java6-parent.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message