aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alasdair Nottingham <...@apache.org>
Subject Re: [DISCUSS] JPA project release
Date Tue, 05 Jul 2011 15:12:43 GMT
I don't think util is ready for a 1.0 release, so an interim is good.

On 5 July 2011 16:11, Timothy Ward <timothyjward@apache.org> wrote:

>
> I agree that we should release as little as is necessary.
>
> I'm not sure if the current changes to JPA would make it 0.3.1 or 0.4. and
> as far as I am aware the only dependency that would also need a release is
> org.apache.aries.uitl. I don't know how close util is to a 1.0 release, so
> we may want an interim delivery.
>
> Regards,
>
> Tim
>
> > From: hughesj@apache.org
> > Date: Tue, 5 Jul 2011 10:23:40 +0100
> > Subject: Re: [DISCUSS] JPA project release
> > To: dev@aries.apache.org
> >
> > Whoops, missed this thread somehow when I just posted another (!)
> > discussion thread. Please take a look at the set of bundles I listed
> > over on the other thread to see what you think.
> >
> > Cheers,
> > Jeremy
> >
> > On 28 June 2011 19:38, Alasdair Nottingham <not@apache.org> wrote:
> > > Go for it.
> > >
> > > On 28 June 2011 11:35, Jean-Baptiste Onofré <jb@nanthrax.net> wrote:
> > >
> > >> Hi Tim,
> > >>
> > >> If JPA works fine with only requirement of a new utils release, it
> makes
> > >> sense for me.
> > >>
> > >> Regards
> > >> JB
> > >>
> > >>
> > >>
> > >> On 06/28/2011 12:23 PM, Timothy Ward wrote:
> > >>
> > >>>
> > >>> Hi,
> > >>>
> > >>> There have been a number of calls on the list for a release, most of
> which
> > >>> seem to be focussed on new JPA function.
> > >>>
> > >>> I think that the following things would need to happen to get JPA
> into a
> > >>> place we can release it:
> > >>>
> > >>> Sort the OSGi 4.3 dependency to remove the Equinox 3.7 download
> pomGet
> > >>> Equinox 3.7 up in Maven
> > >>> Move to the released version of Equinox in the itests
> > >>> The JPA container has dependencies on the changes in the uitls
> project,
> > >>> but I believe it should still work with the latest release of
> blueprint,
> > >>>  proxy and transactions. If this is the case we would only need a
> utils
> > >>> release at the same time.
> > >>>
> > >>> Do we think a release is appropriate? Any other thoughts?
> > >>>
> > >>> Regards,
> > >>>
> > >>> Tim
> > >>>
> > >>>
> > >>
> > >
> > >
> > > --
> > > Alasdair Nottingham
> > > not@apache.org
> > >
>
>



-- 
Alasdair Nottingham
not@apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message