aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mark <mpnutt...@gmail.com>
Subject Re: Apache Aries build still broken locally.
Date Tue, 31 Jul 2012 22:30:42 GMT
Thanks for sorting that out, Holly.

On 31 July 2012 20:02, Holly Cummins <holly.k.cummins@googlemail.com> wrote:

> I've just had a successful build in a clean workspace from a clean
> checkout. I did, however, need to re-deploy the application.modeller
> jar, since the deployed snapshot was incomplete. (Obviously that's a
> one-off thing, since we'd normally expect deployed things not to be
> corrupt!)
>
> I also identified a few snapshots in the sample build where the
> snapshot had been deployed and I'd missed updating it (properties are
> harder for me to update than normal maven dependencies, so I got it
> wrong!). I've fixed those, so I'd be surprised if you see further
> problems.
>
> Again, just to reiterate, the problems I saw were (a) a corrupt
> snapshot (not my fault, but I should have noticed it) and (b) expired
> snapshots where a released version did exist (totally my fault!), so
> building in general against snapshots should work. Nonetheless, we are
> aiming for a build where all dependencies are on released versions,
> unless absolutely necessary. I expect we'll be there within a few more
> release cycles.
>
> On Tue, Jul 31, 2012 at 11:51 AM, Mark Nuttall <mnuttall@apache.org>
> wrote:
> > Hello,
> > Is anyone able to build the Apache Aries code on their local machine? I
> > cannot, for example, build application/ which fails for lack of,
> >
> >   Path to dependency:
> >         1)
> >
> org.apache.aries.application:org.apache.aries.application.management:bundle:1.0.0-SNAPSHOT
> >         2)
> >
> org.apache.aries.application:org.apache.aries.application.deployment.management:jar:1.0.0-SNAPSHOT
> >         3)
> >
> org.apache.aries.application:org.apache.aries.application.modeller:jar:1.0.0-SNAPSHOT
> >
> > What's interesting is that running with -X I see errors of the form
> below,
> > which indicate a problem with the snapshot repository, which is pulled in
> > from /parent/pom.xml:
> >
> > Caused by: java.io.FileNotFoundException:
> >
> http://repository.apache.org/snapshots/org/apache/aries/application/org.apache.aries.application.modeller/1.0.0-SNAPSHOT/org.apache.aries.application.modeller-1.0.0-SNAPSHOT.pom
> >
> >
> > Checking the snapshots under
> >
> https://repository.apache.org/content/groups/snapshots/org/apache/aries/application/org.apache.aries.application.modeller/
> > it does indeed appear that the 1.0.1-SNAPSHOTs are well populated, but
> that
> > the 1.0.0-SNAPSHOT is not.
> >
> > I have completely removed ~/.m2/settings.xml, which makes no difference.
> > I've attached a .zip of my -X output, in case anyone is able to offer any
> > suggestions. Does anyone know how to get around this? Surely I don't
> have to
> > manually edit out all the bogus 1.0.0-SNAPSHOT dependencies just to get
> > things to build locally?
> >
> > Many thanks for any help.
> >
> > Regards,
> > Mark
> >
> >
> >
> >
> > [DEBUG] Connecting to repository: 'apache.snapshots' with url:
> > 'http://repository.apache.org/snapshots'.
> > Downloading:
> >
> http://repository.apache.org/snapshots/org/apache/aries/application/org.apache.aries.application.modeller/1.0.0-SNAPSHOT/org.apache.aries.application.modeller-1.0.0-SNAPSHOT.pom
> > [DEBUG] Unable to locate resource in repository
> > org.apache.maven.wagon.ResourceDoesNotExistException: Unable to locate
> > resource in repository
> >         at
> >
> org.apache.maven.wagon.providers.http.LightweightHttpWagon.fillInputData(LightweightHttpWagon.java:139)
> >         at
> > org.apache.maven.wagon.StreamWagon.getInputStream(StreamWagon.java:116)
> >         at
> > org.apache.maven.wagon.StreamWagon.getIfNewer(StreamWagon.java:88)
> >         at org.apache.maven.wagon.StreamWagon.get(StreamWagon.java:61)
> >         at
> >
> org.apache.maven.artifact.manager.DefaultWagonManager.getRemoteFile(DefaultWagonManager.java:546)
> >         at
> >
> org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:427)
> >         at
> >
> org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:382)
> >         at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:216)
> >         at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:90)
> >         at
> >
> org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:558)
> >         at
> >
> org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
> >         at
> >
> org.apache.maven.project.artifact.MavenMetadataSource.retrieveRelocatedProject(MavenMetadataSource.java:163)
> >         at
> >
> org.apache.maven.project.artifact.MavenMetadataSource.retrieveRelocatedArtifact(MavenMetadataSource.java:94)
> >         at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactCollector.recurse(DefaultArtifactCollector.java:387)
> >         at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactCollector.recurse(DefaultArtifactCollector.java:435)
> >         at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactCollector.collect(DefaultArtifactCollector.java:74)
> >         at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTransitively(DefaultArtifactResolver.java:316)
> >         at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTransitively(DefaultArtifactResolver.java:304)
> >         at
> >
> org.apache.maven.plugin.DefaultPluginManager.resolveTransitiveDependencies(DefaultPluginManager.java:1499)
> >         at
> >
> org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:442)
> >         at
> >
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
> >         at
> >
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
> >         at
> >
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
> >         at
> >
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
> >         at
> >
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
> >         at
> >
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
> >         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
> >         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
> >         at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
> >         at
> > org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
> >         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >         at
> >
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> >         at
> >
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> >         at java.lang.reflect.Method.invoke(Method.java:597)
> >         at
> > org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
> >         at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
> >         at
> > org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
> >         at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> > Caused by: java.io.FileNotFoundException:
> >
> http://repository.apache.org/snapshots/org/apache/aries/application/org.apache.aries.application.modeller/1.0.0-SNAPSHOT/org.apache.aries.application.modeller-1.0.0-SNAPSHOT.pom
> >         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
> > Method)
> >         at
> >
> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
> >         at
> >
> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
> >         at
> java.lang.reflect.Constructor.newInstance(Constructor.java:513)
> >         at
> >
> sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1496)
> >         at java.security.AccessController.doPrivileged(Native Method)
> >         at
> >
> sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1490)
> >         at
> >
> sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1144)
> >         at
> >
> org.apache.maven.wagon.providers.http.LightweightHttpWagon.fillInputData(LightweightHttpWagon.java:122)
> >         ... 37 more
> > Caused by: java.io.FileNotFoundException:
> >
> http://repository.apache.org/snapshots/org/apache/aries/application/org.apache.aries.application.modeller/1.0.0-SNAPSHOT/org.apache.aries.application.modeller-1.0.0-SNAPSHOT.pom
> >         at
> >
> sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1439)
> >         at
> > java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:379)
> >         at
> >
> org.apache.maven.wagon.providers.http.LightweightHttpWagon.fillInputData(LightweightHttpWagon.java:115)
> >         ... 37 more
> > [DEBUG] Using Wagon implementation lightweight from default mapping for
> > protocol http
> > [INFO] Unable to find resource
> >
> 'org.apache.aries.application:org.apache.aries.application.modeller:pom:1.0.0-SNAPSHOT'
> > in repository apache.snapshots (http://repository.apache.org/snapshots)
> > [DEBUG] Skipping disabled repository central
> > [DEBUG] Artifact not found - using stub model: Unable to download the
> > artifact from any repository
> >
> >
> >
> org.apache.aries.application:org.apache.aries.application.modeller:pom:1.0.0-SNAPSHOT
> >
> >
> >
> >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message