aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Holly Cummins (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (ARIES-640) application.utils imports aries.util version [0.4,1.0) but aries.util exports version 0.3.1
Date Fri, 21 Sep 2012 17:55:07 GMT

     [ https://issues.apache.org/jira/browse/ARIES-640?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Holly Cummins resolved ARIES-640.
---------------------------------

       Resolution: Duplicate
    Fix Version/s: 1.0

This has almost certainly been fixed by moving all package versions to 1.0.0 under ARIES-862.
                
> application.utils imports aries.util version [0.4,1.0) but aries.util exports version
0.3.1
> -------------------------------------------------------------------------------------------
>
>                 Key: ARIES-640
>                 URL: https://issues.apache.org/jira/browse/ARIES-640
>             Project: Aries
>          Issue Type: Bug
>          Components: Application
>    Affects Versions: 0.4
>            Reporter: John Ross
>             Fix For: 1.0
>
>         Attachments: patch.patch
>
>
> Given the latest repo contents, I encounter the following error when executing some junit
tests.
> org.osgi.framework.BundleException: The bundle "org.apache.aries.application.utils_0.4.0.SNAPSHOT
[13]" could not be resolved. Reason: Missing Constraint: Import-Package: org.apache.aries.util;
version="[0.4.0,1.0.0)"
> 	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1327)
> 	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1311)
> 	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
> 	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:389)
> 	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1130)
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
> 	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
> 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
> 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
> The manifest within org.apache.aries.application.utils-0.4-SNAPSHOT.jar imports org.apache.aries.util;version="[0.4,1.0)"
but org.apache.aries.util-0.4-SNAPSHOT.jar exports org.apache.aries.util;version="0.3.1".
I've tried "mvn clean install" on those two projects as well as just about everything else.
Am I missing something?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message