aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Nuttall <mnutt...@apache.org>
Subject Re: Subsystems proxy dependency version
Date Sat, 01 Sep 2012 14:18:02 GMT
Hi Holly,
I recently made that change to the proxy code. I think it was under
Aries-909. I've added some metadata to the Proxy weaving hook that declares
the packages that it weaves: the subsystem runtime needs this information.
The first subsystem release will need an accompanying release of proxy.

Regards,
Mark

On 1 September 2012 10:45, Holly Cummins <holly.k.cummins@googlemail.com>wrote:

> When I was looking at the builds, I noticed that the subsystem itests
> depend on proxy-1.0.1-SNAPSHOT, rather than proxy-1.0.0. Is there
> something in the 1.0.1 proxy which the subsystem tests need, John? If
> not it would be better to depend on the released version of the proxy
> bundle, 1.0.0. This avoids us having to do a new release of the proxy
> bundle before we can do any subsystem releasing.
>
> (The subsystem tests will run against the 1.0.1 proxy bundle in the
> AriesWithSnapshotDependencies build, anyway.)
>
> Holly
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message