aries-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Watson <tjwat...@us.ibm.com>
Subject Re: [VOTE] Release Aries JPA 1.0.1
Date Thu, 24 Jul 2014 12:42:32 GMT
Newbie question about the JPA 2.1 support.  Is it expected that the Aries 
JPA bundles will still work with a JPA 2.0 implementation?  or does it 
require a JPA 2.1 implementation and API.  I ask because I am trying to 
update to the latest Aries JPA and it seems to require some new types in 
JPA 2.1 spec.  Is this expected?  Is the only way to get Aries JPA support 
on a JPA 2.0 implementation to use the previous release?

Tom





From:   Jean-Baptiste Onofré <jb@nanthrax.net>
To:     dev@aries.apache.org
Date:   07/16/2014 02:41 PM
Subject:        [VOTE] Release Aries JPA 1.0.1



Hi all,

I submit the following release to your vote:

Aries JPA API 1.0.1
-------------------
                 ChangeLog:
                 [ARIES-1047] Add JPA 2.1 support
                 [ARIES-1006] Refactoring of the parent pom, upgrade to 
OSGi 4.3.1 and 
full Java7 compilation support
                 ARIES-979: Integrate semantic versioning maven plugin in 
aries modules 
(jpa)

Aries JPA Container 1.0.1
-------------------------
                 ChangeLog:
                 [ARIES-1047] Add JPA 2.1 support
                 [ARIES-1018] Don't throw an exception when JPA container 
stops
                 [ARIES-1200] JPA PersistenceBundleManager works with OSGi 
4.2 and 4.3
                 [ARIES-1208] Allow more flexible configuration of 
DataSourceFactory
                 [ARIES-1040] Exception during jpa-container shutdown
                 [ARIES-1006] Refactoring of the parent pom, upgrade to 
OSGi 4.3.1 and 
full Java7 compilation support
                 [ARIES-1173] 'No persistence descriptors' message 
confuses more people 
than it helps
                 [ARIES-1160] Updating JPA container to correctly deal 
with 
Bundle.RESOLVED events when creating a factory
                 [ARIES-1078] JPA container stops locating providers for 
managers (PUs) 
when one provider is found
                 [ARIES-1026] tidy up resources in 
TempBundleDelegatingClassLoader
                 [ARIES-1026] Improve the TempBundleDelegatingClassLoader 
by tracking 
the OSGi ClassLoader Graph
                 [ARIES-1019] JPA weaving hook must be called before proxy 
weaving hook.
 
Aries JPA Container Context 1.0.2
---------------------------------
                 ChangeLog:
                 [ARIES-1047] Add JPA 2.1 support
                 [ARIES-996] JPA does not work for bundles that are 
constituents of 
subsystems.
                 [ARIES-979] Integrate semantic versioning maven plugin in 
aries modules 
(jpa)

Aries JPA Blueprint Aries 1.0.2
-------------------------------
                 ChangeLog:
                 [ARIES-1047] Add JPA 2.1 support 

Staging repository:
https://repository.apache.org/content/repositories/orgapachearies-1007/

Please vote to approve this release:

[ ] +1 Approve the release
[ ] -1 Do not approve the release (please provide specific comments)

This vote will be open for 72 hours.

Thanks,
Regards
JB
-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message