atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Madhan Neethiraj (Jira)" <j...@apache.org>
Subject [jira] [Resolved] (ATLAS-1128) Upgrade frontend-maven-plugin in pom.xml from 0.0.29 to 1.0
Date Mon, 18 May 2020 05:02:00 GMT

     [ https://issues.apache.org/jira/browse/ATLAS-1128?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Madhan Neethiraj resolved ATLAS-1128.
-------------------------------------
    Resolution: Fixed

> Upgrade  frontend-maven-plugin in pom.xml from 0.0.29 to 1.0 
> -------------------------------------------------------------
>
>                 Key: ATLAS-1128
>                 URL: https://issues.apache.org/jira/browse/ATLAS-1128
>             Project: Atlas
>          Issue Type: Improvement
>            Reporter: Nixon Rodrigues
>            Assignee: Nixon Rodrigues
>            Priority: Major
>         Attachments: ATLAS-1128.patch
>
>
>  npm WARN messages are generated as ERROR msg in Maven logs.
> {noformat}
> [INFO] --- frontend-maven-plugin:0.0.29:npm (npm install) @ atlas-dashboardv2 ---
> [INFO] Found proxies: []
> [INFO] Running 'npm install' in /home/nixon/createpatch/apache-atlas/dashboardv2/target
> [ERROR] npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher
to avoid a RegExp DoS issue
> [ERROR] npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher
to avoid a RegExp DoS issue
> [ERROR] npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail
on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use
'npm ls graceful-fs' to find it in the tree.
> [ERROR] npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher
to avoid a RegExp DoS issue
> [ERROR] npm WARN deprecated lodash@1.0.2: lodash@<3.0.0 is no longer maintained. Upgrade
to lodash@^4.0.0.
> [ERROR] npm WARN prefer global jshint@2.8.0 should be installed with -g
> [ERROR] npm WARN prefer global node-gyp@3.4.0 should be installed with -g
> {noformat}
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message