beam-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PerformanceTests_Analysis #445
Date Tue, 23 Jul 2019 01:01:48 GMT
See <https://builds.apache.org/job/beam_PerformanceTests_Analysis/445/display/redirect?page=changes>

Changes:

[ehudm] [BEAM-7679] Add randomness to ITs' BQ dataset name

[robertwb] [BEAM-7060] Support translation of native type variables.

[robertwb] [BEAM-7060] Translate the typing.Iterable type hint.

[robertwb] Minor fixes discovered in migration.

[robertwb] [BEAM-7060] Automated replace of typehints with typing.

[jeff] [BEAM-5191] Support for BigQuery clustering

[github] Remove 4 empty spaces from PR template that mess up Python postcommit

[github] Relax pydot requirements.

[valentyn] Default to PiplelineState.UNKNOWN when job state returned from v1beta3

[valentyn] fixup: Address review feedback.

[ttanay100] Replace old badges for Python PostCommit test with split ones

[robertwb] Post-rewrite lint fixes.

[robertwb] Manual fixes for over-agressive replace.

[robertwb] More conservative typing module translation.

[alireza4263] [BEAM-7783] Adding BeamTableStatistics.

[github] Revert "[BEAM-7060] Migrate to native typing types where possible."

[github] Update Python 3 entry in Python SDK roadmap.

------------------------------------------
Started by timer
[EnvInject] - Loading node environment variables.
Building remotely on apache-beam-jenkins-11 (beam) in workspace <https://builds.apache.org/job/beam_PerformanceTests_Analysis/ws/>
No credentials specified
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url https://github.com/apache/beam.git # timeout=10
Fetching upstream changes from https://github.com/apache/beam.git
 > git --version # timeout=10
 > git fetch --tags --progress https://github.com/apache/beam.git +refs/heads/*:refs/remotes/origin/*
+refs/pull/${ghprbPullId}/*:refs/remotes/origin/pr/${ghprbPullId}/*
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision 8bd3b50715029341e21577ab086301b415c844b3 (origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 8bd3b50715029341e21577ab086301b415c844b3
Commit message: "Merge pull request #9122: [BEAM-7798] Revert "[BEAM-7060] Migrate to native
typing types where possible.""
 > git rev-list --no-walk 23a879f5044bc42a63ceb1394d59d9927bfde79a # timeout=10
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content 
SPARK_LOCAL_IP=127.0.0.1

[EnvInject] - Variables injected successfully.
[beam_PerformanceTests_Analysis] $ /bin/bash -xe /tmp/jenkins1723659908922597695.sh
+ rm -rf PerfKitBenchmarker
[beam_PerformanceTests_Analysis] $ /bin/bash -xe /tmp/jenkins8776596041017323639.sh
+ rm -rf .env
[beam_PerformanceTests_Analysis] $ /bin/bash -xe /tmp/jenkins2508049010068466178.sh
+ virtualenv .env --python=python2.7 --system-site-packages
New python executable in <https://builds.apache.org/job/beam_PerformanceTests_Analysis/ws/.env/bin/python2.7>
Also creating executable in <https://builds.apache.org/job/beam_PerformanceTests_Analysis/ws/.env/bin/python>
Installing setuptools, pip, wheel...
done.
Running virtualenv with interpreter /usr/bin/python2.7
[beam_PerformanceTests_Analysis] $ /bin/bash -xe /tmp/jenkins3860284040639519795.sh
+ .env/bin/pip install --upgrade setuptools pip
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade
your Python as Python 2.7 won't be maintained after that date. A future version of pip will
drop support for Python 2.7.
Requirement already up-to-date: setuptools in ./.env/lib/python2.7/site-packages (41.0.1)
Requirement already up-to-date: pip in ./.env/lib/python2.7/site-packages (19.1.1)
[beam_PerformanceTests_Analysis] $ /bin/bash -xe /tmp/jenkins260808769039662447.sh
+ .env/bin/pip install requests google.cloud.bigquery mock google.cloud.bigtable google.cloud
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade
your Python as Python 2.7 won't be maintained after that date. A future version of pip will
drop support for Python 2.7.
Requirement already satisfied: requests in /usr/lib/python2.7/dist-packages (2.9.1)
Collecting google.cloud.bigquery
  Using cached https://files.pythonhosted.org/packages/d7/72/e88edd9a0b3c16a7b2c4107b1a9d3ff182b84a29f051ae15293e1375d7fe/google_cloud_bigquery-1.17.0-py2.py3-none-any.whl
Collecting mock
  Using cached https://files.pythonhosted.org/packages/05/d2/f94e68be6b17f46d2c353564da56e6fb89ef09faeeff3313a046cb810ca9/mock-3.0.5-py2.py3-none-any.whl
Collecting google.cloud.bigtable
  Using cached https://files.pythonhosted.org/packages/b8/d3/a4670ef8d546bee30c2fc284bd211c7ce3861ae6b4df4d5d7b6382180941/google_cloud_bigtable-0.33.0-py2.py3-none-any.whl
Collecting google.cloud
  Using cached https://files.pythonhosted.org/packages/ba/b1/7c54d1950e7808df06642274e677dbcedba57f75307adf2e5ad8d39e5e0e/google_cloud-0.34.0-py2.py3-none-any.whl
Collecting google-resumable-media>=0.3.1 (from google.cloud.bigquery)
  Using cached https://files.pythonhosted.org/packages/e2/5d/4bc5c28c252a62efe69ed1a1561da92bd5af8eca0cdcdf8e60354fae9b29/google_resumable_media-0.3.2-py2.py3-none-any.whl
Collecting google-cloud-core<2.0dev,>=1.0.0 (from google.cloud.bigquery)
  Using cached https://files.pythonhosted.org/packages/98/7f/ff56aec313787577e262d5a2e306c04aef61c5c274699ff9fb40095e6691/google_cloud_core-1.0.2-py2.py3-none-any.whl
Collecting protobuf>=3.6.0 (from google.cloud.bigquery)
  Using cached https://files.pythonhosted.org/packages/30/bf/d7f8bc958f9eb4661498cde9f7e630da863e43278222d46105712dde4e13/protobuf-3.9.0-cp27-cp27mu-manylinux1_x86_64.whl
Collecting enum34; python_version < "3.4" (from google.cloud.bigquery)
  Using cached https://files.pythonhosted.org/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
Collecting funcsigs>=1; python_version < "3.3" (from mock)
  Using cached https://files.pythonhosted.org/packages/69/cb/f5be453359271714c01b9bd06126eaf2e368f1fddfff30818754b5ac2328/funcsigs-1.0.2-py2.py3-none-any.whl
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from mock) (1.10.0)
Collecting google-api-core[grpc]<2.0.0dev,>=1.6.0 (from google.cloud.bigtable)
  Using cached https://files.pythonhosted.org/packages/5b/3e/48b8ee54f24fd8d5d274bcf642857399f074310032a244353419fc5774b7/google_api_core-1.14.0-py2.py3-none-any.whl
Collecting grpc-google-iam-v1<0.12dev,>=0.11.4 (from google.cloud.bigtable)
Requirement already satisfied: setuptools in ./.env/lib/python2.7/site-packages (from protobuf>=3.6.0->google.cloud.bigquery)
(41.0.1)
Collecting googleapis-common-protos<2.0dev,>=1.6.0 (from google-api-core[grpc]<2.0.0dev,>=1.6.0->google.cloud.bigtable)
Collecting google-auth<2.0dev,>=0.4.0 (from google-api-core[grpc]<2.0.0dev,>=1.6.0->google.cloud.bigtable)
  Using cached https://files.pythonhosted.org/packages/c5/9b/ed0516cc1f7609fb0217e3057ff4f0f9f3e3ce79a369c6af4a6c5ca25664/google_auth-1.6.3-py2.py3-none-any.whl
Collecting pytz (from google-api-core[grpc]<2.0.0dev,>=1.6.0->google.cloud.bigtable)
  Using cached https://files.pythonhosted.org/packages/3d/73/fe30c2daaaa0713420d0382b16fbb761409f532c56bdcc514bf7b6262bb6/pytz-2019.1-py2.py3-none-any.whl
Collecting futures>=3.2.0; python_version < "3.2" (from google-api-core[grpc]<2.0.0dev,>=1.6.0->google.cloud.bigtable)
  Using cached https://files.pythonhosted.org/packages/d8/a6/f46ae3f1da0cd4361c344888f59ec2f5785e69c872e175a748ef6071cdb5/futures-3.3.0-py2-none-any.whl
Collecting grpcio<2.0dev,>=1.8.2; extra == "grpc" (from google-api-core[grpc]<2.0.0dev,>=1.6.0->google.cloud.bigtable)
  Using cached https://files.pythonhosted.org/packages/a5/46/5d08b6e26748ed6f3b5e93d980ea5daa63c3a8200b2ad270645b0e2f9566/grpcio-1.22.0-cp27-cp27mu-manylinux1_x86_64.whl
Collecting rsa>=3.1.4 (from google-auth<2.0dev,>=0.4.0->google-api-core[grpc]<2.0.0dev,>=1.6.0->google.cloud.bigtable)
  Using cached https://files.pythonhosted.org/packages/02/e5/38518af393f7c214357079ce67a317307936896e961e35450b70fad2a9cf/rsa-4.0-py2.py3-none-any.whl
Collecting cachetools>=2.0.0 (from google-auth<2.0dev,>=0.4.0->google-api-core[grpc]<2.0.0dev,>=1.6.0->google.cloud.bigtable)
  Using cached https://files.pythonhosted.org/packages/2f/a6/30b0a0bef12283e83e58c1d6e7b5aabc7acfc4110df81a4471655d33e704/cachetools-3.1.1-py2.py3-none-any.whl
Collecting pyasn1-modules>=0.2.1 (from google-auth<2.0dev,>=0.4.0->google-api-core[grpc]<2.0.0dev,>=1.6.0->google.cloud.bigtable)
  Using cached https://files.pythonhosted.org/packages/91/f0/b03e00ce9fddf4827c42df1c3ce10c74eadebfb706231e8d6d1c356a4062/pyasn1_modules-0.2.5-py2.py3-none-any.whl
Collecting pyasn1>=0.1.3 (from rsa>=3.1.4->google-auth<2.0dev,>=0.4.0->google-api-core[grpc]<2.0.0dev,>=1.6.0->google.cloud.bigtable)
  Using cached https://files.pythonhosted.org/packages/7b/7c/c9386b82a25115cccf1903441bba3cbadcfae7b678a20167347fa8ded34c/pyasn1-0.4.5-py2.py3-none-any.whl
ERROR: google-api-core 1.14.0 has requirement requests<3.0.0dev,>=2.18.0, but you'll
have requests 2.9.1 which is incompatible.
Installing collected packages: google-resumable-media, protobuf, googleapis-common-protos,
pyasn1, rsa, cachetools, pyasn1-modules, google-auth, pytz, futures, enum34, grpcio, google-api-core,
google-cloud-core, google.cloud.bigquery, funcsigs, mock, grpc-google-iam-v1, google.cloud.bigtable,
google.cloud
Successfully installed cachetools-3.1.1 enum34-1.1.6 funcsigs-1.0.2 futures-3.3.0 google-api-core-1.14.0
google-auth-1.6.3 google-cloud-core-1.0.2 google-resumable-media-0.3.2 google.cloud google.cloud.bigquery
google.cloud.bigtable googleapis-common-protos-1.6.0 grpc-google-iam-v1-0.11.4 grpcio-1.22.0
mock-3.0.5 protobuf-3.9.0 pyasn1-0.4.5 pyasn1-modules-0.2.5 pytz-2019.1 rsa-4.0
[beam_PerformanceTests_Analysis] $ /bin/bash -xe /tmp/jenkins8367732294514131259.sh
+ .env/bin/python src/.test-infra/jenkins/verify_performance_test_results_test.py
Traceback (most recent call last):
  File "src/.test-infra/jenkins/verify_performance_test_results_test.py", line 26, in <module>
    from verify_performance_test_results import create_report
  File "<https://builds.apache.org/job/beam_PerformanceTests_Analysis/ws/src/.test-infra/jenkins/verify_performance_test_results.py",>
line 43, in <module>
    from google.cloud import bigquery
  File "<https://builds.apache.org/job/beam_PerformanceTests_Analysis/ws/.env/local/lib/python2.7/site-packages/google/cloud/bigquery/__init__.py",>
line 35, in <module>
    from google.cloud.bigquery.client import Client
  File "<https://builds.apache.org/job/beam_PerformanceTests_Analysis/ws/.env/local/lib/python2.7/site-packages/google/cloud/bigquery/client.py",>
line 40, in <module>
    from google.resumable_media.requests import MultipartUpload
  File "<https://builds.apache.org/job/beam_PerformanceTests_Analysis/ws/.env/local/lib/python2.7/site-packages/google/resumable_media/requests/__init__.py",>
line 673, in <module>
    six.raise_from(new_exc, caught_exc)
  File "/usr/lib/python2.7/dist-packages/six.py", line 718, in raise_from
    raise value
ImportError: ``requests >= 2.18.0`` is required by the ``google.resumable_media.requests``
subpackage.
It can be installed via
    pip install google-resumable-media[requests].
Build step 'Execute shell' marked build as failure

---------------------------------------------------------------------
To unsubscribe, e-mail: builds-unsubscribe@beam.apache.org
For additional commands, e-mail: builds-help@beam.apache.org


Mime
View raw message