beam-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PostCommit_XVR_Direct #805
Date Thu, 28 Jan 2021 00:39:10 GMT
See <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/805/display/redirect?page=changes>

Changes:

[sonam.ramchand] Enabled strict dependency on flink runner

[sonam.ramchand] Added new line

[sonam.ramchand] removed checker-qual

[sonam.ramchand] Removed flink-clients dep

[sonam.ramchand] set enableStrictDependencies:true

[sonam.ramchand] made flink-clients runtimeOnly

[noreply] Remove stray colon.

[zyichi] [BEAM-11679] Override PubsubUnboundedSource transform for dataflow

[zyichi] Populate PubsubMessage message id

[zyichi] Enable tests

[zyichi] Exclude failing FhirIO ITs

[zyichi] Include runner v2 IT tests in java post commit

[Ismaël Mejía] [BEAM-11697] Upgrade Flink runner to Flink versions 1.12.1 and 1.11.3

[shehzaad] strict dependency checking on sdks/io/amazon-web-services*

[shehzaad] move amazon-web-services* changes to another PR

[shehzaad] undo previous erroneous commit

[shehzaad] better use of variables

[randomstep] [BEAM-8725] bump snappy-java to 1.1.8.4

[nielm] Add BigDecimal support for SpannerIO

[noreply] [BEAM-11695] Remove translations.pack_combiners from default optimizers

[Kyle Weaver] [BEAM-11689] Add public.nexus.pentaho.org to offline repositories.

[Chamikara Madhusanka Jayalath] Moving to 2.29.0-SNAPSHOT on master branch.

[noreply] [BEAM-11531] Add pd.to_datetime, handle DeferredBase args in

[Andrew Pilloud] [BEAM-11165] Async ZetaSQL Calc

[noreply] [BEAM-11695] Combiner packing in Dataflow (#13763)


------------------------------------------
[...truncated 791.34 KB...]
  Found link https://files.pythonhosted.org/packages/55/73/bce122d1ed0217b3c1a3439ab16dfa94bbeabd0d31755fcf907493abf39b/pip-20.3-py2.py3-none-any.whl#sha256=3236fe7288d155c238bb6c85d3e784db3a8e592e827b83fea4d36d8b749ecc4b
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*),
version: 20.3
  Found link https://files.pythonhosted.org/packages/03/41/6da553f689d530bc2c337d2c496a40dc9c0fdc6481e5df1f3ee3b8574479/pip-20.3.tar.gz#sha256=9ae7ca6656eac22d2a9b49d024fc24e00f68f4c4d4db673d2d9b525c3dea6e0e
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*),
version: 20.3
  Found link https://files.pythonhosted.org/packages/ab/11/2dc62c5263d9eb322f2f028f7b56cd9d096bb8988fcf82d65fa2e4057afe/pip-20.3.1-py2.py3-none-any.whl#sha256=425e79b20939abbffa7633a91151a882aedc77564d9313e3584eb0416c28c558
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*),
version: 20.3.1
  Found link https://files.pythonhosted.org/packages/cb/5f/ae1eb8bda1cde4952bd12e468ab8a254c345a0189402bf1421457577f4f3/pip-20.3.1.tar.gz#sha256=43f7d3811f05db95809d39515a5111dd05994965d870178a4fe10d5482f9d2e2
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*),
version: 20.3.1
  Skipping link: yanked for reason: <none given>: https://files.pythonhosted.org/packages/3d/0c/01014c0442830eb38d6baef0932fdcb389279ce74295350ecb9fe09e048a/pip-20.3.2-py2.py3-none-any.whl#sha256=8d779b6a85770bc5f624b5c8d4d922ea2e3cd9ce6ee92aa260f12a9f072477bc
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*)
  Skipping link: yanked for reason: <none given>: https://files.pythonhosted.org/packages/51/63/86e147c44335b03055e58a27c791d94fff4baaf08d67852f925ab9b90240/pip-20.3.2.tar.gz#sha256=aa1516c1c8f6f634919cbd8a58fc81432b0fa96f421a97d05a205ee86b07c43d
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*)
  Found link https://files.pythonhosted.org/packages/54/eb/4a3642e971f404d69d4f6fa3885559d67562801b99d7592487f1ecc4e017/pip-20.3.3-py2.py3-none-any.whl#sha256=fab098c8a1758295dd9f57413c199f23571e8fde6cc39c22c78c961b4ac6286d
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*),
version: 20.3.3
  Found link https://files.pythonhosted.org/packages/ca/1e/d91d7aae44d00cd5001957a1473e4e4b7d1d0f072d1af7c34b5899c9ccdf/pip-20.3.3.tar.gz#sha256=79c1ac8a9dccbec8752761cb5a2df833224263ca661477a2a9ed03ddf4e0e3ba
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*),
version: 20.3.3
  Found link https://files.pythonhosted.org/packages/27/79/8a850fe3496446ff0d584327ae44e7500daf6764ca1a382d2d02789accf7/pip-20.3.4-py2.py3-none-any.whl#sha256=217ae5161a0e08c0fb873858806e3478c9775caffce5168b50ec885e358c199d
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*),
version: 20.3.4
  Found link https://files.pythonhosted.org/packages/53/7f/55721ad0501a9076dbc354cc8c63ffc2d6f1ef360f49ad0fbcce19d68538/pip-20.3.4.tar.gz#sha256=6773934e5f5fc3eaa8c5a44949b5b924fc122daa0a8aa9f80c835b4ca2a543fc
(from https://pypi.org/simple/pip/) (requires-python:>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*),
version: 20.3.4
  Found link https://files.pythonhosted.org/packages/de/47/58b9f3e6f611dfd17fb8bd9ed3e6f93b7ee662fb85bdfee3565e8979ddf7/pip-21.0-py3-none-any.whl#sha256=cf2410eedf8735fd842e0fecd4117ca79025d7fe7c161e32f8640ed6ebe5ecb9
(from https://pypi.org/simple/pip/) (requires-python:>=3.6), version: 21.0
  Found link https://files.pythonhosted.org/packages/9e/24/bc928987f35dd0167f21b13a1777c21b9c5917c9894cff93f1c1a6cb8f3b/pip-21.0.tar.gz#sha256=b330cf6467afd5d15f4c1c56f5c95e56a2bfb941c869bed4c1aa517bcb16de25
(from https://pypi.org/simple/pip/) (requires-python:>=3.6), version: 21.0
Given no hashes to check 159 links for project 'pip': discarding no candidates
Removed build tracker: '/tmp/pip-req-tracker-t0bn2iub'
Removing intermediate container 517ad380c308
 ---> ae63e577de77
Step 12/23 : COPY target/license_scripts /tmp/license_scripts/
 ---> 3412f69a1e52
Step 13/23 : COPY target/LICENSE target/go-licenses/* /opt/apache/beam/third_party_licenses/golang/
 ---> ca993b0bb5f6
Step 14/23 : RUN rm /opt/apache/beam/third_party_licenses/golang/LICENSE
 ---> Running in 6e6e62bcd0f0
Removing intermediate container 6e6e62bcd0f0
 ---> 7ee6fe20c6a3
Step 15/23 : COPY target/license_scripts /tmp/license_scripts/
 ---> a8d5e58ce92d
Step 16/23 : RUN if [ "$pull_licenses" = "true" ] ; then     pip install 'pip-licenses<3.0.0;python_version>="3.5"'
&&     pip install 'pip-licenses==1.18.0;python_version<="2.7"' &&    
python /tmp/license_scripts/pull_licenses_py.py &&     pip uninstall -y pip-licenses
&&     rm -rf /root/.cache/pip ;    else     rm -rf /opt/apache/beam/third_party_licenses
;    fi
 ---> Running in 3f8f7d636804
Collecting pip-licenses<3.0.0
  Downloading pip_licenses-2.3.0-py3-none-any.whl (14 kB)
Collecting PTable
  Downloading PTable-0.9.2.tar.gz (31 kB)
Building wheels for collected packages: PTable
  Building wheel for PTable (setup.py): started
  Building wheel for PTable (setup.py): finished with status 'done'
  Created wheel for PTable: filename=PTable-0.9.2-py3-none-any.whl size=22907 sha256=1a64aa7b2654ed7a6c8d699aebca93606eca8347dc93e2be60d651b56b0cd40d
  Stored in directory: /root/.cache/pip/wheels/f3/65/67/71f473ec87ea4554d1bdfb1b5128cfe1414c2b113b72a1ee8e
Successfully built PTable
Installing collected packages: PTable, pip-licenses
Successfully installed PTable-0.9.2 pip-licenses-2.3.0
Ignoring pip-licenses: markers 'python_version <= "2.7"' don't match your environment
INFO:root:Successfully pulled licenses for 89 dependencies
Found existing installation: pip-licenses 2.3.0
Uninstalling pip-licenses-2.3.0:
  Successfully uninstalled pip-licenses-2.3.0
Removing intermediate container 3f8f7d636804
 ---> 568e02c893f4
Step 17/23 : RUN rm -rf /tmp/license_scripts
 ---> Running in e13d721b8684
Removing intermediate container e13d721b8684
 ---> 8e4e2cd46fc3
Step 18/23 : RUN pip freeze --all
 ---> Running in ec4c72d63e3c
absl-py==0.11.0
apache-beam @ file:///opt/apache/beam/tars/apache-beam.tar.gz
astunparse==1.6.3
avro-python3==1.8.2
cachetools==4.2.1
certifi==2020.12.5
cffi==1.14.4
chardet==4.0.0
crcmod==1.7
Cython==0.29.13
dataclasses==0.8
dill==0.3.1.1
docopt==0.6.2
fastavro==1.0.0.post1
fasteners==0.16
future==0.18.2
gast==0.3.3
google-api-core==1.22.0
google-apitools==0.5.31
google-auth==1.24.0
google-auth-oauthlib==0.4.2
google-cloud-bigquery==1.26.1
google-cloud-bigtable==1.0.0
google-cloud-build==2.0.0
google-cloud-core==1.4.1
google-cloud-datastore==1.7.4
google-cloud-dlp==1.0.0
google-cloud-language==1.3.0
google-cloud-pubsub==1.0.2
google-cloud-spanner==1.19.1
google-cloud-videointelligence==1.16.1
google-cloud-vision==1.0.0
google-crc32c==1.1.2
google-pasta==0.2.0
google-resumable-media==1.2.0
googleapis-common-protos==1.52.0
grpc-google-iam-v1==0.12.3
grpcio==1.29.0
grpcio-gcp==0.2.2
guppy3==3.0.9
h5py==2.10.0
hdfs==2.5.8
httplib2==0.12.0
idna==2.10
importlib-metadata==3.4.0
Keras-Preprocessing==1.1.2
libcst==0.3.16
Markdown==3.3.3
mmh3==2.5.1
mock==2.0.0
mypy-extensions==0.4.3
nose==1.3.7
numpy==1.17.3
oauth2client==4.1.3
oauthlib==3.1.0
opt-einsum==3.3.0
pandas==1.1.4
pbr==5.5.1
pip==21.0
proto-plus==1.13.0
protobuf==3.12.2
protorpc==0.12.0
PTable==0.9.2
pyarrow==0.16.0
pyasn1==0.4.8
pyasn1-modules==0.2.8
pycparser==2.20
pydot==1.4.1
PyHamcrest==1.10.1
pymongo==3.9.0
pyparsing==2.4.7
python-dateutil==2.8.1
python-gflags==3.0.6
pytz==2019.3
PyYAML==5.4.1
requests==2.25.1
requests-oauthlib==1.3.0
rsa==4.7
scipy==1.4.1
setuptools==52.0.0
six==1.15.0
tenacity==6.3.1
tensorboard==2.4.1
tensorboard-plugin-wit==1.8.0
tensorflow==2.3.0
tensorflow-estimator==2.3.0
termcolor==1.1.0
typing-extensions==3.7.4.3
typing-inspect==0.6.0
urllib3==1.26.3
Werkzeug==1.0.1
wheel==0.36.2
wrapt==1.12.1
zipp==3.4.0
Removing intermediate container ec4c72d63e3c
 ---> daad33d9dbe2
Step 19/23 : RUN pip check
 ---> Running in 8a9379225802
No broken requirements found.
Removing intermediate container 8a9379225802
 ---> 25eafdd8b80e
Step 20/23 : COPY target/LICENSE /opt/apache/beam/
 ---> df96f808590a
Step 21/23 : COPY target/NOTICE /opt/apache/beam/
 ---> e2976f7c01cf
Step 22/23 : ADD target/launcher/linux_amd64/boot /opt/apache/beam/
 ---> 282a82967d5f
Step 23/23 : ENTRYPOINT ["/opt/apache/beam/boot"]
 ---> Running in f4583f9d071a
Removing intermediate container f4583f9d071a
 ---> b9495907f890
Successfully built b9495907f890
Successfully tagged apache/beam_python3.6_sdk:2.29.0.dev

> Task :sdks:python:test-suites:direct:xlang:validatesCrossLanguageRunnerSetup
Launching Java expansion service @ 18090
Launching Python expansion service @ 18089

> Task :sdks:python:test-suites:direct:xlang:validatesCrossLanguageRunnerCleanup
Stopping expansion service pid: 30680.
Stopping expansion service pid: 30684.

> Task :sdks:java:io:google-cloud-platform:compileJava
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

> Task :sdks:java:io:google-cloud-platform:classes
> Task :sdks:java:io:google-cloud-platform:jar
> Task :sdks:java:extensions:sql:extractIncludeProto
> Task :sdks:java:extensions:sql:generateProto NO-SOURCE
> Task :sdks:java:extensions:sql:compileJava
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

> Task :sdks:java:extensions:sql:classes
> Task :sdks:java:extensions:sql:jar
> Task :sdks:java:extensions:sql:zetasql:compileJava
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

> Task :sdks:java:extensions:sql:zetasql:classes
> Task :sdks:java:extensions:sql:zetasql:jar

> Task :sdks:java:extensions:sql:expansion-service:compileJava
Note: <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/sdks/java/extensions/sql/expansion-service/src/main/java/org/apache/beam/sdk/extensions/sql/expansion/ExternalSqlTransformRegistrar.java>
uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

> Task :sdks:java:extensions:sql:expansion-service:classes
> Task :sdks:java:extensions:sql:expansion-service:shadowJar

> Task :sdks:python:test-suites:direct:xlang:fnApiJobServerCleanup FAILED
sh: 1: .: Can't open <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/-1278429404/bin/activate>

FAILURE: Build completed with 2 failures.

1: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':sdks:python:test-suites:direct:xlang:fnApiJobServerSetup'.
> Process 'command 'sh'' finished with non-zero exit value 2

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to
get more log output. Run with --scan to get full insights.
==============================================================================

2: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':sdks:python:test-suites:direct:xlang:fnApiJobServerCleanup'.
> Process 'command 'sh'' finished with non-zero exit value 2

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to
get more log output. Run with --scan to get full insights.
==============================================================================

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.8/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 37m 46s
169 actionable tasks: 145 executed, 20 from cache, 4 up-to-date
Gradle was unable to watch the file system for changes. The inotify watches limit is too low.

Publishing build scan...
https://gradle.com/s/sfy7ow2nc7li4

Build step 'Invoke Gradle script' changed build result to FAILURE
Build step 'Invoke Gradle script' marked build as failure

---------------------------------------------------------------------
To unsubscribe, e-mail: builds-unsubscribe@beam.apache.org
For additional commands, e-mail: builds-help@beam.apache.org


Mime
View raw message