beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ib...@apache.org
Subject [beam] branch master updated: [BEAM-11419] Update Flink supported versions in the website
Date Thu, 07 Jan 2021 23:00:32 GMT
This is an automated email from the ASF dual-hosted git repository.

ibzib pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/beam.git


The following commit(s) were added to refs/heads/master by this push:
     new 2239b3a  [BEAM-11419] Update Flink supported versions in the website
     new c5badae  Merge pull request #13620 from iemejia/website-flink-versions
2239b3a is described below

commit 2239b3a1fb1fbc1e36d7454bcae7bb7323031ebe
Author: Ismaël Mejía <iemejia@gmail.com>
AuthorDate: Mon Dec 28 15:19:28 2020 +0100

    [BEAM-11419] Update Flink supported versions in the website
---
 .../site/content/en/documentation/runners/flink.md | 42 +++++++++++++++++++++-
 1 file changed, 41 insertions(+), 1 deletion(-)

diff --git a/website/www/site/content/en/documentation/runners/flink.md b/website/www/site/content/en/documentation/runners/flink.md
index d173f70..e1f814c 100644
--- a/website/www/site/content/en/documentation/runners/flink.md
+++ b/website/www/site/content/en/documentation/runners/flink.md
@@ -326,7 +326,45 @@ To find out which version of Flink is compatible with Beam please see
the table
   <th>Artifact Id</th>
 </tr>
 <tr>
-  <td rowspan="3">&ge; 2.21.0</td>
+  <td rowspan="5">&ge; 2.27.0</td>
+  <td>1.12.x <sup>*</sup></td>
+  <td>beam-runners-flink-1.12</td>
+</tr>
+<tr>
+  <td>1.11.x <sup>*</sup></td>
+  <td>beam-runners-flink-1.11</td>
+</tr>
+<tr>
+  <td>1.10.x</td>
+  <td>beam-runners-flink-1.10</td>
+</tr>
+<tr>
+  <td>1.9.x</td>
+  <td>beam-runners-flink-1.9</td>
+</tr>
+<tr>
+  <td>1.8.x</td>
+  <td>beam-runners-flink-1.8</td>
+</tr>
+<tr>
+  <td rowspan="4">2.25.0 - 2.26.0</td>
+  <td>1.11.x <sup>*</sup></td>
+  <td>beam-runners-flink-1.11</td>
+</tr>
+<tr>
+  <td>1.10.x</td>
+  <td>beam-runners-flink-1.10</td>
+</tr>
+<tr>
+  <td>1.9.x</td>
+  <td>beam-runners-flink-1.9</td>
+</tr>
+<tr>
+  <td>1.8.x</td>
+  <td>beam-runners-flink-1.8</td>
+</tr>
+<tr>
+  <td rowspan="3">2.21.0 - 2.24.0</td>
   <td>1.10.x</td>
   <td>beam-runners-flink-1.10</td>
 </tr>
@@ -421,6 +459,8 @@ To find out which version of Flink is compatible with Beam please see
the table
 </tr>
 </table>
 
+<sup>*</sup> This version does not have a published docker image for the Flink
Job Service.
+
 For retrieving the right Flink version, see the [Flink downloads page](https://flink.apache.org/downloads.html).
 
 For more information, the [Flink Documentation](https://ci.apache.org/projects/flink/flink-docs-stable/)
can be helpful.


Mime
View raw message