buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicolas Modrzyk" <hellon...@gmail.com>
Subject Buildr.settings before buildfile located
Date Thu, 09 Oct 2008 01:45:45 GMT
Hi list,

I am using buildr 1.3.3 (snapshot) not standalone, but embedded into
my own script.

I have a set of dependencies, and one of them would be:
AXIOM = group("axiom-api", "axiom-dom", "axiom-impl",
:under=>"org.apache.ws.commons.axiom", :version=>"1.2.7")

That call fails with the following:
Internal error: Called Buildr.settings before buildfile located (RuntimeError)

The full stack trace would be:
/Users/niko/tools/gemrepository/gems/buildr-1.3.3/lib/buildr/core/application.rb:144:in
`settings': Internal error: Called Buildr.settings before buildfile
located (RuntimeError)
	from /Users/niko/tools/gemrepository/gems/buildr-1.3.3/lib/buildr/core/application.rb:375:in
`settings'
	from /Users/niko/tools/gemrepository/gems/buildr-1.3.3/lib/buildr/packaging/artifact.rb:431:in
`local'
	from /Users/niko/tools/gemrepository/gems/buildr-1.3.3/lib/buildr/packaging/artifact.rb:458:in
`locate'
	from /Users/niko/tools/gemrepository/gems/buildr-1.3.3/lib/buildr/packaging/artifact.rb:593:in
`artifact'
	from /Users/niko/tools/gemrepository/gems/buildr-1.3.3/lib/buildr/packaging/artifact.rb:686:in
`group'
	from /Users/niko/tools/gemrepository/gems/buildr-1.3.3/lib/buildr/packaging/artifact.rb:686:in
`map'
	from /Users/niko/tools/gemrepository/gems/buildr-1.3.3/lib/buildr/packaging/artifact.rb:686:in
`group'
	from /Users/niko/projects/tempo.svn/rsc/scripts/../build/dependencies.rb:21

I went and look at applications.rb, and there's obviously the line
firing the RuntimeError:
def settings
      fail "Internal error: Called Buildr.settings before buildfile
located" unless rakefile
      @settings ||= Settings.new(self)
end

If I comment it out, everything works fine, and it was also working
fine with earlier versions of buildr.

Is there any reason why we're now forcing the check for a rakefile ?
Or anyway I can disable it (apart from touching buildr source code)?

Thanks,

Nicolas,

Mime
View raw message