buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Rogers <wjrog...@gmail.com>
Subject Re: Buildr 1.4.0RC2 is out
Date Mon, 26 Apr 2010 22:39:03 GMT
On Mon, Apr 26, 2010 at 2:33 PM, Antoine Toulme <antoine@lunar-ocean.com> wrote:
>> 1882 examples, 48 failures
>> rake aborted!
>> Command C:/Ruby/bin/ruby.exe [...] failed
>
> Not sure. If you run with --trace, it gives a lot more info and should send
> a backtrace.

I think maybe the "error" I reported after running "rake spec" is
normal? It's rake saying, "Hey, that task 'spec' you ran failed!"
because the number of failures is non-zero. Can anyone who uses
rake/RSpec more than me confirm?

> The fix is to remove 1.3.0. What happens is that Buildr requires a few gems,
> which lazily require rspec with version >0, and your system picks up the
> latest version. When buildr gets around to dictate to start 1.2.9, rubygems
> throws an error.

Confirmed that uninstalling rspec 1.3.0 fixes those particular specs.
Still 48 failures mostly related to Windows filesystem stuff.


Thanks,

-- Will

Mime
View raw message