buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sshark <ssh...@gmail.com>
Subject Re: strange buildr installation problem
Date Thu, 14 Apr 2011 03:13:37 GMT
Yes, it works for me with ruby 1.8.7 out of the box without upgrading
gem (as mentioned). It failed with ruby 1.9.2 out of the box. Gem
required msvcrt-ruby18.dll to run.

On Thu, Apr 14, 2011 at 5:42 AM, Ilya Pyatigorskiy <atamur@gmail.com> wrote:
> It works with ruby, if i don't do a gem update. Then i'm getting this (a
> working config!):
>
> looser@SHINREI /c/dev/gl52 (master)
> $ gem list --local
>
> *** LOCAL GEMS ***
>
> atoulme-Antwrap (0.7.1)
> builder (2.1.2)
> buildr (1.4.5 x86-mswin32)
> diff-lcs (1.1.2)
> highline (1.5.1)
> hoe (2.3.3)
> json_pure (1.4.3)
> minitar (0.5.3)
> net-sftp (2.0.4)
> net-ssh (2.0.23)
> rake (0.8.7)
> rjb (1.3.2 x86-mswin32-60)
> rspec (2.1.0)
> rspec-core (2.1.0)
> rspec-expectations (2.1.0)
> rspec-mocks (2.1.0)
> rubyforge (2.0.3)
> rubyzip (0.9.4)
> xml-simple (1.0.12)
>
> looser@SHINREI /c/dev/gl52 (master)
> $ gem env
> RubyGems Environment:
>   - RUBYGEMS VERSION: 1.5.2
>   - RUBY VERSION: 1.8.7 (2011-02-18 patchlevel 334) [i386-mingw32]
>   - INSTALLATION DIRECTORY: c:/bin/Ruby187/lib/ruby/gems/1.8
>   - RUBY EXECUTABLE: c:/bin/Ruby187/bin/ruby.exe
>   - EXECUTABLE DIRECTORY: c:/bin/Ruby187/bin
>   - RUBYGEMS PLATFORMS:
>     - ruby
>     - x86-mingw32
>   - GEM PATHS:
>      - c:/bin/Ruby187/lib/ruby/gems/1.8
>      - c:/Users/looser/.gem/ruby/1.8
>   - GEM CONFIGURATION:
>      - :update_sources => true
>      - :verbose => true
>      - :benchmark => false
>      - :backtrace => false
>      - :bulk_threshold => 1000
>   - REMOTE SOURCES:
>      - http://rubygems.org/
>
>
>
> On Wed, Apr 13, 2011 at 11:27 AM, sshark <sshark@gmail.com> wrote:
>>
>> I had the same problem some time back and used JRuby instead
>>
>> On Wed, Apr 13, 2011 at 3:22 PM, Ilya Pyatigorskiy <atamur@gmail.com>
>> wrote:
>> > Hi,
>> >
>> > installing buildr on a new pc (the usual way: "gem install buildr
>> > --platform
>> > mswin32") I'm not able to run it:
>> >
>> > looser@SHINREI ~
>> > $ gem list --local
>> >
>> > *** LOCAL GEMS ***
>> >
>> > atoulme-Antwrap (0.7.1)
>> > builder (2.1.2)
>> > buildr (1.4.5 x86-mswin32)
>> > diff-lcs (1.1.2)
>> > highline (1.5.1)
>> > hoe (2.3.3)
>> > json_pure (1.4.3)
>> > minitar (0.5.3)
>> > net-sftp (2.0.4)
>> > net-ssh (2.0.23)
>> > rake (0.8.7)
>> > rjb (1.3.2 x86-mswin32-60)
>> > rspec (2.1.0)
>> > rspec-core (2.1.0)
>> > rspec-expectations (2.1.0)
>> > rspec-mocks (2.1.0)
>> > rubyforge (2.0.3)
>> > rubygems-update (1.7.2)
>> > rubyzip (0.9.4)
>> > xml-simple (1.0.12)
>> >
>> > looser@SHINREI ~
>> > $ buildr
>> > c:/bin/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:926:in
>> > `report_activate_error': RubyGem version error: buildr(1.4.5 not >= 0)
>> > (Gem::LoadError)
>> >        from c:/bin/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:244:in
>> > `activate_dep'
>> >        from c:/bin/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:236:in
>> > `activate'
>> >        from c:/bin/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:1307:in
>> > `gem'
>> >        from c:/bin/Ruby187/bin/buildr:18
>> >
>> > The error message is somewhat misleading - how come I don't have 1.4.5
>> > when
>> > it's exactly the version I've got.
>> >
>> > Any ideas?
>> >
>> > Thank you!
>> >
>
>

Mime
View raw message