cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Ellis (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CASSANDRA-393) rename storageendpoint overloads for clarity
Date Fri, 28 Aug 2009 17:54:32 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-393?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12748920#action_12748920
] 

Jonathan Ellis commented on CASSANDRA-393:
------------------------------------------

03
    rename remaining StorageService methods

02
    r/m LoadVerbHandler and unused endpoint-related code

01
    CASSANDRA-393 r/m unnecessary IReplicationStrategy interface.  rename AbstractStrategy
-> AbstractReplicationStrategy.  rename endpoint methods in ARS.

> rename storageendpoint overloads for clarity
> --------------------------------------------
>
>                 Key: CASSANDRA-393
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-393
>             Project: Cassandra
>          Issue Type: Task
>          Components: Core
>            Reporter: Jonathan Ellis
>            Assignee: Jonathan Ellis
>            Priority: Minor
>             Fix For: 0.4
>
>         Attachments: 0001-CASSANDRA-393-r-m-unnecessary-IReplicationStrategy-int.txt,
0002-r-m-LoadVerbHandler-and-unused-endpoint-related-code.txt, 0003-rename-remaining-methods.txt
>
>
> StorageService:
> getNLiveStorageEndPoint(String):List<EndPoint>
> getNStorageEndPoint(String):EndPoint[]
> getNStorageEndPoint(Token):EndPoint[]
> getNStorageEndPoint(Token, Map<Token, EndPoint>):EndPoint[]
> getNStorageEndPointMap(String):Map<EndPoint, EndPoint>
> getNStorageEndPoints(String[]):Map<String, EndPoint[]>
> some of these should be getWriteSEP. Some getHintedSEP. Some getReadSEP.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message