cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Kelly (Jira)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-16605) The dependencies in the Cassandra DEB package prevent installation on Ubuntu 20.04+
Date Wed, 28 Jul 2021 11:25:02 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-16605?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17388697#comment-17388697
] 

Michael Kelly commented on CASSANDRA-16605:
-------------------------------------------

Hi,

when will 3.11.11 appear in downloads so that I can update my local apt cache and then upgrade.

> The dependencies in the Cassandra DEB package prevent installation on Ubuntu 20.04+
> -----------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-16605
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-16605
>             Project: Cassandra
>          Issue Type: Task
>          Components: Packaging
>            Reporter: Michael Kelly
>            Assignee: Brandon Williams
>            Priority: Normal
>             Fix For: 3.0.25, 3.11.11
>
>
> The DEB package for Cassandra has a dependency on 'python >= 2.7'.
> In Ubuntu 18.04 there is a package called 'python' which installs python2.7.
> This package has been removed in Ubuntu 20.04 so the dependency cannot be satisified.
>  
> Proposed solution:
> Change the dependency 'python >= 2.7' to something like 'python2 >= 2.7 OR python3
>= 3.6'.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org


Mime
View raw message