cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Semb Wever (Jira)" <j...@apache.org>
Subject [jira] [Created] (CASSANDRA-16781) Fix upgrade dtests after cassandra-4.0 branch bumped to 4.0.1
Date Thu, 01 Jul 2021 11:58:00 GMT
Michael Semb Wever created CASSANDRA-16781:
----------------------------------------------

             Summary: Fix upgrade dtests after cassandra-4.0 branch bumped to 4.0.1
                 Key: CASSANDRA-16781
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-16781
             Project: Cassandra
          Issue Type: Bug
          Components: Test/dtest/python
            Reporter: Michael Semb Wever


{noformat}
Regression
dtest-upgrade.upgrade_tests.paging_test.TestPagingDataNodes2RF1_Upgrade_current_4_0_x_To_indev_4_0_x.test_static_columns_paging
(from Cassandra dtests)

Failing for the past 1 build (Since Unstable#116 )
Took 46 sec.
 Failed 1 times in the last 29 runs. Flakiness: 3%, Stability: 96%
Error Message
TypeError: '<' not supported between instances of 'str' and 'int'
Stacktrace
self = <abc.TestPagingDataNodes2RF1_Upgrade_current_4_0_x_To_indev_4_0_x object at 0x7f5ff1817c10>

    @since('2.0.6')
    def test_static_columns_paging(self):
        """
            Exercises paging with static columns to detect bugs
            @jira_ticket CASSANDRA-8502.
            """
        cursor = self.prepare(row_factory=named_tuple_factory)
        cursor.execute("CREATE TABLE test (a int, b int, c int, s1 int static, s2 int static,
PRIMARY KEY (a, b))")
    
        for is_upgraded, cursor in self.do_upgrade(cursor, row_factory=named_tuple_factory):
>           min_version = min(self.get_node_versions())

upgrade_tests/paging_test.py:661: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
/usr/lib/python3.8/distutils/version.py:52: in __lt__
    c = self._cmp(other)
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 

self = LooseVersion ('4.0-rc1'), other = LooseVersion ('4.0.1')

    def _cmp (self, other):
        if isinstance(other, str):
            other = LooseVersion(other)
    
        if self.version == other.version:
            return 0
>       if self.version < other.version:
E       TypeError: '<' not supported between instances of 'str' and 'int'

/usr/lib/python3.8/distutils/version.py:337: TypeError
{noformat}
from https://ci-cassandra.apache.org/job/Cassandra-4.0/116/testReport/junit/dtest-upgrade.upgrade_tests.paging_test/TestPagingDataNodes2RF1_Upgrade_current_4_0_x_To_indev_4_0_x/test_static_columns_paging/


ref: https://the-asf.slack.com/archives/CK23JSY2K/p1625125464283300 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org


Mime
View raw message