cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Semb Wever (Jira)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-16822) Wrong cqlsh python library location in cassandra-3.11.11-1 rhel packages
Date Mon, 02 Aug 2021 07:05:00 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-16822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17391394#comment-17391394
] 

Michael Semb Wever commented on CASSANDRA-16822:
------------------------------------------------

h3. To Reproduce
{code}
docker run -it centos /bin/sh

sh-4.4# echo '[cassandra]
name=Apache Cassandra
baseurl=https://downloads.apache.org/cassandra/redhat/311x
gpgcheck=1
repo_gpgcheck=1
gpgkey=https://downloads.apache.org/cassandra/KEYS' > /etc/yum.repos.d/cassandra.repo

sh-4.4# yum -y update
sh-4.4# yum -y install cassandra
sh-4.4# yum -y install python2

sh-4.4# cassandra -R

sh-4.4# cqlsh
{code}

Replacing with python3 doesn't help, as mentioned above cqlsh forces python2.

Running with centos7 gives the same error (though python2 is already installed).

h4. Workaround
Works on both centos 7 and 8.
{code}
cp -r /usr/lib/python3.6/site-packages/cqlshlib /usr/lib/python2.7/site-packages/cqlshlib
{code}

> Wrong cqlsh python library location in cassandra-3.11.11-1 rhel packages 
> -------------------------------------------------------------------------
>
>                 Key: CASSANDRA-16822
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-16822
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Packaging
>            Reporter: Ville Savolainen
>            Assignee: Brandon Williams
>            Priority: Normal
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> cqlsh does not work because cqlshlib is in wrong location while I think it should be
in python2.7 for cassandra-3.11
> cassandra.spec seems to define python interpreter to /usr/bin/python so I think build
environment has been changed after 3.11.10 so /usr/bin/python points to python3 instead of
python2.
> cassandra-3.11.10 did have chqlshlib in python2.7 site-packages
> {noformat}
> $ rpm -qpl cassandra-3.11.11-1.noarch.rpm |grep cql
> warning: cassandra-3.11.11-1.noarch.rpm: Header V4 RSA/SHA512 Signature, key ID 0b84c041:
NOKEY
> /etc/cassandra/default.conf/cqlshrc.sample
> /usr/bin/cqlsh
> /usr/bin/cqlsh.py
> /usr/bin/debug-cql
> /usr/lib/python3.6/site-packages/cqlshlib
> /usr/lib/python3.6/site-packages/cqlshlib/__init__.py
> /usr/lib/python3.6/site-packages/cqlshlib/copyutil.py
> /usr/lib/python3.6/site-packages/cqlshlib/cql3handling.py
> /usr/lib/python3.6/site-packages/cqlshlib/cqlhandling.py
> /usr/lib/python3.6/site-packages/cqlshlib/cqlshhandling.py
> /usr/lib/python3.6/site-packages/cqlshlib/displaying.py
> /usr/lib/python3.6/site-packages/cqlshlib/formatting.py
> /usr/lib/python3.6/site-packages/cqlshlib/helptopics.py
> /usr/lib/python3.6/site-packages/cqlshlib/pylexotron.py
> /usr/lib/python3.6/site-packages/cqlshlib/saferscanner.py
> /usr/lib/python3.6/site-packages/cqlshlib/sslhandling.py
> /usr/lib/python3.6/site-packages/cqlshlib/tracing.py
> /usr/lib/python3.6/site-packages/cqlshlib/util.py
> /usr/lib/python3.6/site-packages/cqlshlib/wcwidth.py
> {noformat}
>  
> Pull request to cassandra-3.11: https://github.com/apache/cassandra/pull/1124



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org


Mime
View raw message