cayenne-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aadamc...@apache.org
Subject [cayenne-website] branch master updated: 4.2 docs update
Date Thu, 30 Jul 2020 07:26:21 GMT
This is an automated email from the ASF dual-hosted git repository.

aadamchik pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/cayenne-website.git


The following commit(s) were added to refs/heads/master by this push:
     new 35fa094  4.2 docs update
35fa094 is described below

commit 35fa0942f0837d04ff0fa3028418bbaa146be3da
Author: Andrus Adamchik <andrus@objectstyle.com>
AuthorDate: Thu Jul 30 10:19:04 2020 +0300

    4.2 docs update
    
    .. restoring version as 4.2.M1
---
 src/main/site/content/docs/4.2/cayenne-guide.html  | 52 +++++++++++-----------
 .../content/docs/4.2/getting-started-db-first.html |  2 +-
 .../content/docs/4.2/getting-started-guide.html    |  2 +-
 .../site/content/docs/4.2/getting-started-rop.html |  2 +-
 4 files changed, 29 insertions(+), 29 deletions(-)

diff --git a/src/main/site/content/docs/4.2/cayenne-guide.html b/src/main/site/content/docs/4.2/cayenne-guide.html
index eb69c7f..45db2ab 100644
--- a/src/main/site/content/docs/4.2/cayenne-guide.html
+++ b/src/main/site/content/docs/4.2/cayenne-guide.html
@@ -123,7 +123,7 @@ menu:
         &lt;plugin&gt;
             &lt;groupId&gt;org.apache.cayenne.plugins&lt;/groupId&gt;
             &lt;artifactId&gt;cayenne-modeler-maven-plugin&lt;/artifactId&gt;
-            &lt;version&gt;4.2&lt;/version&gt;
+            &lt;version&gt;4.2.M1&lt;/version&gt;
         &lt;/plugin&gt;
     &lt;/plugins&gt;
 &lt;/build&gt;</code></pre> 
@@ -363,7 +363,7 @@ total 24
       <pre class="highlight"><code class="language-xml xml" data-lang="xml">&lt;dependency&gt;
    &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
    &lt;artifactId&gt;cayenne-server&lt;/artifactId&gt;
-   &lt;version&gt;4.2&lt;/version&gt;
+   &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -375,7 +375,7 @@ total 24
     </div> 
     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-server:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-server:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -3117,7 +3117,7 @@ ServerRuntime runtime = ServerRuntime.builder()
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;plugin&gt;
 	&lt;groupId&gt;org.apache.cayenne.plugins&lt;/groupId&gt;
 	&lt;artifactId&gt;cayenne-maven-plugin&lt;/artifactId&gt;
-	&lt;version&gt;4.2&lt;/version&gt;
+	&lt;version&gt;4.2.M1&lt;/version&gt;
 
 	&lt;configuration&gt;
         &lt;cayenneProject&gt;${project.basedir}/src/main/resources/cayenne/cayenne-project.xml&lt;/cayenneProject&gt;
@@ -3701,7 +3701,7 @@ ServerRuntime runtime = ServerRuntime.builder()
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;dependency&gt;
     &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-cache-invalidation&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -3710,7 +3710,7 @@ ServerRuntime runtime = ServerRuntime.builder()
     <h4 id="gradle-2"><a class="anchor" href="#gradle-2"></a>4.1.2. Gradle</h4>

     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-cache-invalidation:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-cache-invalidation:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -3793,7 +3793,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;dependency&gt;
     &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-commitlog&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -3802,7 +3802,7 @@ public class MyEntity extends _MyEntity {
     <h4 id="gradle-3"><a class="anchor" href="#gradle-3"></a>4.2.2. Gradle</h4>

     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-commitlog:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-commitlog:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -3873,7 +3873,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;dependency&gt;
     &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-crypto&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -3882,7 +3882,7 @@ public class MyEntity extends _MyEntity {
     <h4 id="gradle-4"><a class="anchor" href="#gradle-4"></a>4.3.2. Gradle</h4>

     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-crypto:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-crypto:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -3996,7 +3996,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;dependency&gt;
     &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-jcache&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -4005,7 +4005,7 @@ public class MyEntity extends _MyEntity {
     <h4 id="gradle-5"><a class="anchor" href="#gradle-5"></a>4.4.2. Gradle</h4>

     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-jcache:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-jcache:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -4107,7 +4107,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;dependency&gt;
     &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-project-compatibility&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -4116,7 +4116,7 @@ public class MyEntity extends _MyEntity {
     <h4 id="gradle-6"><a class="anchor" href="#gradle-6"></a>4.5.2. Gradle</h4>

     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-project-compatibility:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-project-compatibility:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -4139,7 +4139,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;dependency&gt;
     &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-velocity&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -4148,7 +4148,7 @@ public class MyEntity extends _MyEntity {
     <h4 id="gradle-7"><a class="anchor" href="#gradle-7"></a>4.6.2. Gradle</h4>

     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-velocity:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-velocity:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -4196,7 +4196,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;dependency&gt;
     &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-web&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -4205,7 +4205,7 @@ public class MyEntity extends _MyEntity {
     <h4 id="gradle-8"><a class="anchor" href="#gradle-8"></a>4.7.2. Gradle</h4>

     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-web:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-web:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -4222,7 +4222,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;dependency&gt;
     &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-osgi&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -4231,7 +4231,7 @@ public class MyEntity extends _MyEntity {
     <h4 id="gradle-9"><a class="anchor" href="#gradle-9"></a>4.8.2. Gradle</h4>

     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-osgi:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-osgi:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -4248,7 +4248,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;dependency&gt;
     &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-rop-server&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 &lt;/dependency&gt;</code></pre> 
      </div> 
     </div> 
@@ -4257,7 +4257,7 @@ public class MyEntity extends _MyEntity {
     <h5 id="gradle-10"><a class="anchor" href="#gradle-10"></a>4.9.2. Gradle</h5>

     <div class="listingblock"> 
      <div class="content"> 
-      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-rop-server:4.2'</code></pre> 
+      <pre class="highlight"><code class="language-Groovy Groovy" data-lang="Groovy">compile
'org.apache.cayenne:cayenne-rop-server:4.2.M1'</code></pre> 
      </div> 
     </div> 
    </div> 
@@ -4434,7 +4434,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-xml xml" data-lang="xml">&lt;plugin&gt;
     &lt;groupId&gt;org.apache.cayenne.plugins&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-maven-plugin&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 
     &lt;configuration&gt;
         &lt;map&gt;${project.basedir}/src/main/resources/my.map.xml&lt;/map&gt;
@@ -4691,7 +4691,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-XML XML" data-lang="XML">&lt;plugin&gt;
     &lt;groupId&gt;org.apache.cayenne.plugins&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-maven-plugin&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
 
     &lt;executions&gt;
         &lt;execution&gt;
@@ -4861,7 +4861,7 @@ public class MyEntity extends _MyEntity {
       <pre class="highlight"><code class="language-xml xml" data-lang="xml">&lt;plugin&gt;
     &lt;groupId&gt;org.apache.cayenne.plugins&lt;/groupId&gt;
     &lt;artifactId&gt;cayenne-maven-plugin&lt;/artifactId&gt;
-    &lt;version&gt;4.2&lt;/version&gt;
+    &lt;version&gt;4.2.M1&lt;/version&gt;
     &lt;executions&gt;
         &lt;execution&gt;
             &lt;configuration&gt;
@@ -4897,7 +4897,7 @@ public class MyEntity extends _MyEntity {
     }
     // add Cayenne Gradle Plugin
     dependencies {
-        classpath group: 'org.apache.cayenne.plugins', name: 'cayenne-gradle-plugin', version:
'4.2'
+        classpath group: 'org.apache.cayenne.plugins', name: 'cayenne-gradle-plugin', version:
'4.2.M1'
     }
 }
 
diff --git a/src/main/site/content/docs/4.2/getting-started-db-first.html b/src/main/site/content/docs/4.2/getting-started-db-first.html
index c283bfc..d6cdbc4 100644
--- a/src/main/site/content/docs/4.2/getting-started-db-first.html
+++ b/src/main/site/content/docs/4.2/getting-started-db-first.html
@@ -117,7 +117,7 @@ ALTER TABLE painting ADD FOREIGN KEY (GALLERY_ID) REFERENCES gallery (ID)
ON DEL
     <div class="listingblock"> 
      <div class="content"> 
       <pre class="highlight"><code class="language-xml xml" data-lang="xml">&lt;properties&gt;
-    &lt;cayenne.version&gt;4.2&lt;/cayenne.version&gt;
+    &lt;cayenne.version&gt;4.2.M1&lt;/cayenne.version&gt;
 &lt;/properties&gt;</code></pre> 
      </div> 
     </div> 
diff --git a/src/main/site/content/docs/4.2/getting-started-guide.html b/src/main/site/content/docs/4.2/getting-started-guide.html
index 5667403..79c40c7 100644
--- a/src/main/site/content/docs/4.2/getting-started-guide.html
+++ b/src/main/site/content/docs/4.2/getting-started-guide.html
@@ -288,7 +288,7 @@ menu:
     &lt;version&gt;0.0.1-SNAPSHOT&lt;/version&gt;
 
     &lt;properties&gt;
-        &lt;cayenne.version&gt;4.2&lt;/cayenne.version&gt; <i class="conum"
data-value="1"></i><b>(1)</b>
+        &lt;cayenne.version&gt;4.2.M1&lt;/cayenne.version&gt; <i class="conum"
data-value="1"></i><b>(1)</b>
         &lt;maven.compiler.source&gt;1.8&lt;/maven.compiler.source&gt; <i
class="conum" data-value="2"></i><b>(2)</b>
         &lt;maven.compiler.target&gt;1.8&lt;/maven.compiler.target&gt;
     &lt;/properties&gt;
diff --git a/src/main/site/content/docs/4.2/getting-started-rop.html b/src/main/site/content/docs/4.2/getting-started-rop.html
index c077110..37f5342 100644
--- a/src/main/site/content/docs/4.2/getting-started-rop.html
+++ b/src/main/site/content/docs/4.2/getting-started-rop.html
@@ -105,7 +105,7 @@ weight: 40
             &lt;groupId&gt;org.apache.cayenne&lt;/groupId&gt;
             &lt;artifactId&gt;cayenne-client-jetty&lt;/artifactId&gt;
             &lt;!-- Here specify the version of Cayenne you are actually using --&gt;
-            &lt;version&gt;4.2&lt;/version&gt;
+            &lt;version&gt;4.2.M1&lt;/version&gt;
         &lt;/dependency&gt;
         &lt;dependency&gt;
         &lt;groupId&gt;com.caucho&lt;/groupId&gt;


Mime
View raw message