cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alessandro Caviglione <c.alessan...@gmail.com>
Subject Re: Port forwarding on nic2
Date Fri, 05 Dec 2014 22:46:28 GMT
Thank you very much!
I'm still learning use API! :)



On Fri, Dec 5, 2014 at 1:53 PM, Jayapal Reddy Uradi <
jayapalreddy.uradi@citrix.com> wrote:

> Hi,
>
> I have tried configuring the static for nic2 from the UI.
> UI is not showing the VM nic2 ip addresses, it is showing primary/default
> nic2.
>
> API is working fine. So I will file UI bug.
>
> Thanks,
> Jayapal
>
> On 03-Dec-2014, at 10:41 AM, Vadim Kimlaychuk <Vadim.Kimlaychuk@Elion.ee>
> wrote:
>
> > Hi Alessandro,
> >
> >         I think default NIC is tightly coupled with default route and
> default GW. You may have several NICs at your system but only once is used
> for communication to outside world. If you have several shared networks
> choose one that is connected to Internet as default. If both connected --
> choose any of them.
> >
> > Regards,
> >
> > Vadim.
> > ________________________________________
> > From: Alessandro Caviglione [c.alessandro@gmail.com]
> > Sent: Wednesday, December 03, 2014 2:19
> > To: users@cloudstack.apache.org
> > Subject: Re: Port forwarding on nic2
> >
> > Hellooo,
> > I see another "strange" thing...
> > I'm also a newbie of CS and I'm understanding just now some concepts
> but...
> > what mean "default" nic?
> > Why in an instance I have a default nic that I can change (if I've more
> > than one nic)?
> > And why, also if I change the default nic, I still can only configure
> port
> > forwarding on the first nic I configured for my instance?
> > When I configure a port forwarding and I select the instance, a dropdown
> > menu should show the IP address of the instance, but I see only primary?
> > Maybe I'm experiencing a bug?
> >
> > On Sun, Nov 30, 2014 at 10:21 PM, Alessandro Caviglione <
> > c.alessandro@gmail.com> wrote:
> >
> >> Hi guys,
> >> I'm experiencing an issue about port forwarding.
> >> I've deployed an instance with 2 NICs, both isolated network.
> >> Now I've configured some services in the instance, some listening on
> NIC 1
> >> IP and some listening on NIC 2 IP.
> >> IP are in two different subnet, both assigned by CS DHCP.
> >> Now, I click the second network in the network menu > View IP Address >
> >> Public IP > Configuration tab > Port forwarding  then I create a new
> port
> >> forwarding rule specifying the port, protocol and clicking the "Add"
> button
> >> to specify the instance IP.
> >> The instance appear in the popup but when I select the instance I just
> can
> >> choose the "Primary" IP that is corresponding to the NIC 1.
> >>
> >> Something I wrong?
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message