cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Weller <>
Subject Re: Issue Upgrade CloudStack 4.3 vs 4.7/4.8
Date Wed, 21 Sep 2016 16:21:27 GMT

Take a look at this document for how to change the DB password:

Make sure you back everything up first.

- Si

From: Gian Paolo Buono <>
Sent: Wednesday, September 21, 2016 11:11 AM
Subject: Issue Upgrade CloudStack 4.3 vs 4.7/4.8

Hi all,

I have an installation of Cloudstack 4.3 (Centos 6.5) advanced zone with XenServer and I have
following this procedure for 4.7 and 4.8


The issue appear when I restart management services after upgrade, in management-server.log

2016-09-21 17:56:38,155 WARN  [c.c.u.d.T.Transaction] (main:null) (logid:) Unable to load
db configuration, using defaults with 5 connections. Falling back on assumed datasource on
localhost:3306 using username:password=cloud:cloud. Please check your configuration
org.jasypt.exceptions.EncryptionInitializationException: java.lang.InternalError
java.sql.SQLException: Access denied for user 'cloud'@'localhost' (using password: YES)
    at com.mysql.jdbc.SQLError.createSQLException(
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(

I have tried to change the mysql password:

I have tried to change the parameters in /etc/cloudstack/management/ but it seems
that they are not applied

Any idea ?


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message