cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dag Sonstebo <>
Subject Re: Unable to remove host server
Date Mon, 20 Mar 2017 12:08:13 GMT
Hi Andrei,

This isn’t a bug – this is how CloudStack works. You can’t delete a host unless it’s
in maintenance mode (even though the delete button shows). The disable function is different
– this simply removes the host from possible hosts when starting a new VM etc., i.e. you
would use this function when you don’t want any more workload assigned to that host. As
a result putting the host into maintenance mode evacuates all VMs, putting into disabled state
leaves all VMs running.

Dag Sonstebo
Cloud Architect

On 20/03/2017, 11:55, "Andrei Mikhailovsky" <> wrote:

    Hi Gabriel,
    I have found out what was the problem and managed to delete the host from the GUI and
the cloudmonkey helped me with it. There seems to be a bug in the GUI version and
perhaps earlier. 
    The way that I tried to delete the host before was to Disable the host first and click
on the Delete (X) icon. This has presented me with a message window asking to confirm the
deletion and an option to use force delete. I have tried to delete with and without the force
delete option checked, and both options didn't work.
    However, when I tried to delete via the cloudmonkey, it has given me an error message
stating that I can only delete the host which is in the Maintenance Mode. There was no such
message in the GUI and the Delete option becomes available after you switch the host into
the Disabled mode.
    Thus, I have tried to delete the host by first making it in the Maintenance Mode and pressing
the Delete button.
    It seems that there is a logic bug in the ACS gui where it gives me the Delete option
after switching the host to the Disabled state, even though according to the backend, you
can't delete the host in that mode.

53 Chandos Place, Covent Garden, London  WC2N 4HSUK

----- Original Message -----
    > From: "Andrei Mikhailovsky" <>
    > To: "users" <>
    > Sent: Monday, 20 March, 2017 10:22:58
    > Subject: Re: Unable to remove host server
    > Hi
    > Gabriel,
    > I am using KVM and all servers are running on Ubuntu 14.04 LTS
    > I will try the cloudmonkey route and let you know.
    > Cheers
    > ----- Original Message -----
    >> From: "Rafael Weingärtner" <>
    >> To: "users" <>
    >> Sent: Friday, 17 March, 2017 15:50:59
    >> Subject: Re: Unable to remove host server
    >> Could you try to remove the host using cloudmonkey?
    >> What hypervisor are you using?
    >> On Fri, Mar 17, 2017 at 11:49 AM, Andrei Mikhailovsky <
    >>> wrote:
    >>> Hi,
    >>> There is absolutely nothing related to host removal on the management
    >>> server end. So, not even a job registration for the removal. I have tried
    >>> to use several browsers to execute this. Nothing helps.
    >>> Thus I thought to change db to indicate that the host have been removed.
    >>> But what tables do I need to modify to remove the host properly and cleanly?
    >>> It used to work for me prior to upgrading to 4.9.x.x.
    >>> Andrei
    >>> ----- Original Message -----
    >>> > From: "Gabriel Beims Bräscher" <>
    >>> > To: "users" <>
    >>> > Sent: Wednesday, 8 March, 2017 13:29:13
    >>> > Subject: Re: Unable to remove host server
    >>> > Hi Andrei,
    >>> >
    >>> > I would avoid manual changes in the DB.
    >>> > Have you checked the Apache CloudStack log
    >>> > (/var/log/cloudstack/management/management-server.log)?
    >>> >
    >>> > Please, share your log so we can help you with the troubleshooting.
    >>> >
    >>> > Cheers,
    >>> > Gabriel.
    >>> >
    >>> > 2017-03-08 9:48 GMT-03:00 Andrei Mikhailovsky <
    >>> >:
    >>> >
    >>> >> Hello everyone,
    >>> >>
    >>> >> I am running ACS on Ubuntu 14.04 server. I have tried to
    >>> >> one of the host servers from the cluster, but I am not able to do
    >>> After
    >>> >> pressing the Remove button, I can see the spinning circle, but nothing
    >>> is
    >>> >> happening. I've also tried to do it with the Force remove option
    >>> >> without much luck either. Tried to do it on a few browsers, still
    >>> same
    >>> >> issue. Nothing is happening in the management server logs. No errors,
    >>> >> exceptions ,etc.
    >>> >>
    >>> >> How can I remove the host server? Can I simply marked it as removed
    >>> the
    >>> >> db? If so, apart from the host table, do I need to make changes
to any
    >>> >> other tables?
    >>> >>
    >>> >> Thanks
    >> --
    > > Rafael Weingärtner

View raw message