cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Letha Etzkorn <etzk...@gmail.com>
Subject Fwd: Cloudstack quick install help
Date Sat, 08 Aug 2020 19:45:13 GMT
Hi,


I've run all the way through the install multiple times, and I can't create
an instance because no templates or ISOs show up in the GUI after I select
Add Instance.

There are templates and isos visible when I click the Templates tab.

I have tried adding my own ISO but I get the error:
There is no secondary storage VM for downloading template to image store.
nfs://172.16.10.2/export/secondary

When I go to the System VMs tab, it says that I have both a primary storage
and a secondary storage VM and that both are running.

On my CentOS manager/compute node, I ran the following commands to check
the nfs:
rpcinfo -p 172.16.10.2
(see attached file pic1.jpg)
exportfs -v
(see attached file pic2.jpg)

My install setup:  I am running VirtualBox on Ubuntu 1804.  I have an
Ubuntu Virtual Router running on a VM (it is 172.16.10.1 gateway on
internal network) connects to a CentOS VM over the internal network
(created from a CentOS-7-x86_64-Minimal-1804.iso file), the CentOS VM is
172.16.10.2.  I have my CentOS virtualbox VM set up such that it does
nested virtualization, when I do "grep --color "vmx" /proc/cpuinfo" on my
CentOS vms I see red vmx-es).

At all points during my install, before every new step, I checked to see if
the previous services were working.  For example, before doing the
management setup I checked to see if nfs and rpcbind were working
(systemctl status rpcbind, systemctl status nfs), etc.

when I did lsmod | grep kvm, I got the expected result.

In my management server log, I had these ERRORs:
migrateDatafromIsoIdInVolumesTable:Exception: Unknown column 'iso_id1" in
"field list'
PropertiesUtil...Unable to find file: commands.properties

In my management server log, I also had these Debug statements:
ConSoleProxyManagerImpl ...Skip capacity scan as there is no Primary
Storage in 'Up" state

I have included  my log files at this link:
https://drive.google.com/drive/folders/10WkgiPNqjV0mhc81dsLGYmg-doVhd6d5?usp=sharing


I have read through previously posted help for these problems, and nothing
I have seen has fixed my problem, or I was unable to do it.

Help is greatly appreciated.

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message