cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rakesh Venkatesh <www.rakeshv....@gmail.com>
Subject Re: Unable to ping secondary NIC ip of a VM in VPC
Date Mon, 10 Aug 2020 15:09:33 GMT
Ok no problem.

As suggested, I manually edited /etc/network/interfaces files to add eth1
and restarted networking service.
Ping works fine now from VR


# ping 10.10.2.25
PING 10.10.2.25 (10.10.2.25): 56 data bytes
64 bytes from 10.10.2.25: icmp_seq=0 ttl=64 time=1.981 ms
64 bytes from 10.10.2.25: icmp_seq=1 ttl=64 time=1.322 ms
64 bytes from 10.10.2.25: icmp_seq=2 ttl=64 time=1.124 ms
64 bytes from 10.10.2.25: icmp_seq=3 ttl=64 time=1.376 ms
^C--- 10.10.2.25 ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss

On Mon, Aug 10, 2020 at 5:04 PM Thomas Joseph <thomas.job07@gmail.com>
wrote:

> Sorry, I've not used v4.14, so someone else can comment on it being a bug.
>
> I would advise you to enable the related nic in the file named interfaces
> and restart the network service to check if that works.
>
>
> On Mon, 10 Aug 2020, 8:29 pm Rakesh Venkatesh, <www.rakeshv.com@gmail.com>
> wrote:
>
> > Hello Thomas
> >
> >
> > Thanks for the reply. It looks like the NIC is not configured properly in
> > VM. I dont see IP 10.10.2.23 being configured
> >
> > # ip a
> > 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group
> > default qlen 1
> >     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
> >     inet 127.0.0.1/8 scope host lo
> >        valid_lft forever preferred_lft forever
> >     inet6 ::1/128 scope host
> >        valid_lft forever preferred_lft forever
> > 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
> state
> > UP group default qlen 1000
> >     link/ether 02:00:78:24:00:01 brd ff:ff:ff:ff:ff:ff
> >     inet 10.10.1.51/24 brd 10.10.1.255 scope global eth0
> >        valid_lft forever preferred_lft forever
> >     inet6 fe80::78ff:fe24:1/64 scope link
> >        valid_lft forever preferred_lft forever
> > 3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group
> default
> > qlen 1000
> >     link/ether 02:00:1f:ed:00:0e brd ff:ff:ff:ff:ff:ff
> >
> >
> >
> > I removed the secondary NIC, stopped the vm, added secondary NIC and
> > started the VM. The extra NIC is still not configured in VM.
> > Is this a bug?
> >
> > On Mon, Aug 10, 2020 at 4:46 PM Thomas Joseph <thomas.job07@gmail.com>
> > wrote:
> >
> > > Hello Venkatesh,
> > >
> > > I'm guessing from the output provided that you have tried to ping the
> ip
> > > from the VR.
> > > Have you checked if the NIC is up on the VM?
> > >  you can run tcpdump on the related VM to check if the icmp packets are
> > > reaching the VM.
> > >
> > > Regards
> > > Thomas
> > >
> > > On Mon, 10 Aug 2020, 8:06 pm Rakesh Venkatesh, <
> > www.rakeshv.com@gmail.com>
> > > wrote:
> > >
> > > > Hello,
> > > >
> > > > I have created a VPC with three tiers in it (tier1, tier2. tier3)
> using
> > > > cloudstack 4.14.0.0 version with Ubuntu16 as OS for mgt, agent
> > > > I created a VM in tier1 and I am able to ping its IP address
> > > >
> > > > # ping 10.10.1.51
> > > > PING 10.10.1.51 (10.10.1.51): 56 data bytes
> > > > 64 bytes from 10.10.1.51: icmp_seq=0 ttl=64 time=2.273 ms
> > > > 64 bytes from 10.10.1.51: icmp_seq=1 ttl=64 time=1.690 ms
> > > > ^C--- 10.10.1.51 ping statistics ---
> > > >
> > > >
> > > > After adding secondary NIC to vm from tier2 or tier3 then I am not
> able
> > > to
> > > > ping that IP address.
> > > >
> > > > # ping 10.10.2.23
> > > > PING 10.10.2.23 (10.10.2.23): 56 data bytes
> > > > 92 bytes from 10.10.2.254: Destination Host Unreachable
> > > > 92 bytes from 10.10.2.254: Destination Host Unreachable
> > > > 92 bytes from 10.10.2.254: Destination Host Unreachable
> > > > 92 bytes from 10.10.2.254: Destination Host Unreachable
> > > > ^C--- 10.10.2.23 ping statistics ---
> > > >
> > > >
> > > >
> > > > Dchphost content
> > > >
> > > > # cat /etc/dhcphosts.txt
> > > > 02:00:72:36:00:01,10.10.2.83,tier12,infinite
> > > > 02:00:2f:16:00:0c,set:10_10_2_23,10.10.2.23,tier11,infinite
> > > > 02:00:78:24:00:01,10.10.1.51,tier11,infinite
> > > >
> > > >
> > > >
> > > > Dhcpopts content
> > > >
> > > >
> > > > # cat /etc/dhcpopts.txt
> > > > 10_10_2_23,3
> > > > 10_10_2_23,6
> > > > 10_10_2_23,15
> > > >
> > > >
> > > > I don't see any errors in /var/log/cloud.log on VR when secondary nic
> > is
> > > > added.
> > > > Is there any other I can troubleshoot this or look for logs?
> > > >
> > > > --
> > > > Thanks and regards
> > > > Rakesh
> > > >
> > >
> >
> >
> > --
> > Thanks and regards
> > Rakesh venkatesh
> >
>


-- 
Thanks and regards
Rakesh venkatesh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message