cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject Re: Windows 10 KVM becoming inaccessible
Date Sun, 09 Aug 2020 15:48:23 GMT
Hi Dave,

I've not specifically worked with Windows guest VMs on KVM, but what you've described is largely
subject to a guest OS support by the hypervisor, in this case the specific libvirt/qemu/linux-kernel
version and any guest tools/drivers that must be installed inside the Windows guest VM. You've
yourself acknowledged that the issue is not seen in your older CentOS6 based environment.

To rule out CloudStack (a) you may add or upgrade hosts in a cluster to use qemu-ev (enterprise
qemu release by CentOS SIG https://wiki.centos.org/SpecialInterestGroup/Virtualization, i.e.
install the centos-release-qemu-ev pkg) or (b) you may add a new cluster with Ubuntu 18.04
KVM hosts and recreate your Windows VM setup. Or, it could be a specific Windows build or
requires additional drivers (such as https://www.linux-kvm.org/page/WindowsGuestDrivers/Download_Drivers).


Hope this helps.


Regards.

________________________________
From: Dave Lapointe <davel@island.net>
Sent: Saturday, August 8, 2020 00:48
To: users@cloudstack.apache.org <users@cloudstack.apache.org>
Subject: Windows 10 KVM becoming inaccessible

Hi,

I've been lurking on this group for a few years now and have found the information that people
have posted here to be quite helpful for me to understand CloudStack better.  I've never replied
here because there are always far more knowledgeable people on this list who can offer much
better insight than I ever could.

An issue has arisen recently that I can't find any solution for.  I apologize ahead of time
if this is the wrong list to post to.

I recently configured a new server to run CloudStack using Centos 7.8.2003 and CloudStack
4.14, and configured some Windows 10 LTSB KVM guests.  This is a fairly specialized server,
so the configuration is a little unusual.  It's configured to use the "cloudbr0" software
bridge for the guest network which is then routed externally through a single NIC.  Also,
because the VM's will never be migrated, I've set guest.cpu.mode=host-passthrough.

What's been happening though is that the VM's will just freeze sometimes, apparently randomly.
 Sometimes it will happen during boot, or a couple minutes after connecting by RDP.  And sometimes
the VM won't freeze at all.  I haven't been able to determine a pattern as to when this will
happen.  And I haven't found anything in the logs that might help me understand what's happening
(/var/log/messages and /var/log/cloudstack/management/management-server.log).  I've checked
on the QEMU and Linux forums, but have only found a bit of information about VM's freezing
for people using specific graphics drivers with passthrough for their graphics cards.  I tried
removing guest.cpu.mode=host-passthrough but that made no difference.

What's especially odd to me is that this didn't happen with older systems I've created (eg.
CentOS 6 and CloudStack 4.9).  I've setup half a dozen or so using the same configuration
as this system, just older software.

I can't tell if this is related to CloudStack (maybe there is something in the guest parameters
that is causing this), or if this is strictly a KVM issue.  And since I can't find anything
in the logs I don't know where else to look.  I'm hoping to get some suggestions from this
list so that I can do some more digging.

Thanks,
Dave

rohit.yadav@shapeblue.comĀ 
www.shapeblue.com
3 London Bridge Street,  3rd floor, News Building, London  SE1 9SGUK
@shapeblue
  
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message