cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject Re: Cloudstack quick install help
Date Sun, 09 Aug 2020 17:30:32 GMT
Hi Letha,

I looked at the logs, looks like there is no primary storage in your environment:
2020-08-08 13:29:37,957 DEBUG [c.c.c.ConsoleProxyManagerImpl] (consoleproxy-1:ctx-0ba7fb5b)
(logid:94a1ab94) Skip capacity scan as there is no Primary Storage in 'Up' state

Here are some checks you can do:

  *   Have you deployed a zone with cluster, host, primary and secondary storage? http://docs.cloudstack.apache.org/en/4.14.0.0/quickinstallationguide/qig.html#setting-up-a-zone
  *
If you go to Infra -> Zone -> do you have the zone enabled?
  *   If you go to Infra -> {Host, Primary Storage} in the UI do you see a KVM host that
is UP and the primary storage that is UP? Check if you've configured the correct server host/IP
and path for the primary and secondary storage, and check the KVM agent logs for error.
  *   Is there a secondary storage in the zone, and have you seeded the 4.14 systemvmtemplate
on it?

Regards.

________________________________
From: etzkorl gmail <etzkorl@gmail.com>
Sent: Sunday, August 9, 2020 22:43
To: users@cloudstack.apache.org <users@cloudstack.apache.org>
Subject: Re: Cloudstack quick install help

Hi,
I used the quick install guide for CentOS.

If the primary and secondary storage aren’t running I’m not sure why—see my rpcinfo
and exportfs Commands as shown in my first email, nfs is running. Also my system VMs tab says
a primary and secondary VM are running.  I did define a zone.  It shows up on the UI as working.

Can you tell me something specific to check and where to check it?  As far as I can tell right
now I have the things you’ve mentioned.

Letha



rohit.yadav@shapeblue.com 
www.shapeblue.com
3 London Bridge Street,  3rd floor, News Building, London  SE1 9SGUK
@shapeblue
  
 

> On Aug 9, 2020, at 10:38 AM, Rohit Yadav <rohit.yadav@shapeblue.com> wrote:
>
> Hi Letha,
>
> I think you don't have any primary and/or secondary storage defined in your environment
and there's no SSVM (secondary storage VM) running for your zone. Also check if your zone
is enabled? Until you've storage available and SSVM running, CloudStack won't be able to register/add
templates and ISOs or allow you to deploy VMs.
>
> Have you tried the QIG (quick install guide) for CentOS7 - http://docs.cloudstack.apache.org/en/4.14.0.0/quickinstallationguide/qig.html
?
> If you're a Ubuntu user, you can try https://rohityadav.cloud/blog/cloudstack-kvm/
>
> Hope this helps.
>
>
> Regards.
>
> ________________________________
> From: Letha Etzkorn <etzkorl@gmail.com>
> Sent: Sunday, August 9, 2020 01:15
> To: users@cloudstack.apache.org <users@cloudstack.apache.org>
> Subject: Fwd: Cloudstack quick install help
>
> Hi,
> 
> I've run all the way through the install multiple times, and I can't create an instance
because no templates or ISOs show up in the GUI after I select Add Instance.
>
> There are templates and isos visible when I click the Templates tab.
>
> I have tried adding my own ISO but I get the error:
> There is no secondary storage VM for downloading template to image store. nfs://172.16.10.2/export/secondary<http://172.16.10.2/export/secondary>
>
> When I go to the System VMs tab, it says that I have both a primary storage and a secondary
storage VM and that both are running.
>
> On my CentOS manager/compute node, I ran the following commands to check the nfs:
> rpcinfo -p 172.16.10.2
> (see attached file pic1.jpg)
> exportfs -v
> (see attached file pic2.jpg)
>
> My install setup:  I am running VirtualBox on Ubuntu 1804.  I have an Ubuntu Virtual
Router running on a VM (it is 172.16.10.1 gateway on internal network) connects to a CentOS
VM over the internal network (created from a CentOS-7-x86_64-Minimal-1804.iso file), the CentOS
VM is 172.16.10.2.  I have my CentOS virtualbox VM set up such that it does nested virtualization,
when I do "grep --color "vmx" /proc/cpuinfo" on my CentOS vms I see red vmx-es).
>
> At all points during my install, before every new step, I checked to see if the previous
services were working.  For example, before doing the management setup I checked to see if
nfs and rpcbind were working (systemctl status rpcbind, systemctl status nfs), etc.
>
> when I did lsmod | grep kvm, I got the expected result.
>
> In my management server log, I had these ERRORs:
> migrateDatafromIsoIdInVolumesTable:Exception: Unknown column 'iso_id1" in "field list'
> PropertiesUtil...Unable to find file: commands.properties
>
> In my management server log, I also had these Debug statements:
> ConSoleProxyManagerImpl ...Skip capacity scan as there is no Primary Storage in 'Up"
state
>
> I have included  my log files at this link:
> https://drive.google.com/drive/folders/10WkgiPNqjV0mhc81dsLGYmg-doVhd6d5?usp=sharing
>
>
> I have read through previously posted help for these problems, and nothing I have seen
has fixed my problem, or I was unable to do it.
>
> Help is greatly appreciated.
>
>
>
>
> [cid:173cf8f158ed0aab95a1][cid:173cf8f158ed0b8d0db2]
>
> rohit.yadav@shapeblue.com
> www.shapeblue.com<http://www.shapeblue.com>
> 3 London Bridge Street,  3rd floor, News Building, London  SE1 9SGUK
> @shapeblue
>
>
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message