cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject [DISCUSS] Deprecating support for Ubuntu 16.04 in ACS 4.15?
Date Sat, 29 Aug 2020 09:47:10 GMT
All,

Ubuntu 16.04 does not have JRE11 package as well as some packages for Python3 such as python3-distutils:
https://packages.ubuntu.com/search?suite=default&section=all&arch=any&keywords=python3-distutils&searchon=names

The Java 11 JRE requirement was introduced starting the 4.14.0.0 release and in the release
notes workaround for JRE installation was mentioned [0]. With master/4.15 support for Python3
was added for KVM hosts and the management server but a critical issue [1] was recently identified
due to which cloudstack-agent would fail installation on the older Ubuntu 16.04 due to missing
python3-distutil (and other) dependencies.

Ubuntu 16.04 will reach the end of standard support by April 2021 [2][3], and the next 4.15
release will add support for Ubuntu 20.04 [4][5] - so should we:

(a) remove Ubuntu 16.04 from our list of supported distribution (for KVM host and management
server) in 4.15?
(b) (if there are users using 16.04) document workaround for installation/upgrade in the 4.15
release/upgrade notes?

Thoughts, feedback? Thanks.

[0] http://docs.cloudstack.apache.org/en/4.14.0.0/upgrading/upgrade/upgrade-4.13.html#java-version-requirement

[1] https://github.com/apache/cloudstack/issues/4280

[2] https://wiki.ubuntu.com/Releases

[3] https://lists.ubuntu.com/archives/ubuntu-announce/2016-April/000207.html

[4] Wei's Ubuntu 20.04 PR https://github.com/apache/cloudstack/pull/4069

[5] Wei's Ubuntu 20.04 PR included with support for CentOS8 PR https://github.com/apache/cloudstack/pull/4068


Regards.

rohit.yadav@shapeblue.comĀ 
www.shapeblue.com
3 London Bridge Street,  3rd floor, News Building, London  SE1 9SGUK
@shapeblue
  
 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message