cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rafael del Valle <rva...@privaz.io.INVALID>
Subject Re: Failed to build 4.15.1: cloud-plugin-user-authenticator-ldap
Date Fri, 09 Jul 2021 13:31:14 GMT
Hi Rene!

Looks like the artifact is no longer in maven central. Is it used for building ACS also? 

Newer versions are available, and probably are compatible.

Will have a look at it.


Regards,
Rafael

On Fri, 2021-07-09 03:15 PM, Rene Moser <mail@renemoser.net> wrote:
> 
Hi
> 
> I tried to update the cloudstack test container [1] for ansible 
> integration tests to 4.15.1 but the build failed with a missing mvn 
> dependency:
> 
> [ERROR] Failed to execute goal 
> org.apache.maven.plugins:maven-dependency-plugin:3.1.1:resolve-plugins 
> (resolve-plugins) on
> project cloud-plugin-user-authenticator-ldap: Failure to find 
> com.btmatthews.maven.plugins:ldap-maven-plugin:jar:1.1.3 in
> https://repo.maven.apache.org/maven2
> 
> This hasn't changed since 2 years 
> https://github.com/apache/cloudstack/blob/main/plugins/user-authenticators/ldap/pom.xml#L35
> 
> Any hints how to resolve?
> 
> Regards
> René
> 
> 
> [1] https://github.com/ansible/cloudstack-test-container/pull/13/
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message