cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darrin Hüsselmann <Darrin.Husselm...@shapeblue.com>
Subject Re: Secondary storage doesn't work
Date Mon, 19 Jul 2021 07:03:46 GMT
Hi Andy,

No worries, have a look at what is set in the global variable "host". You can find global
variables by going to Configuration -> Global Settings. You can use the search field to
narrow down the options. If you must make a change there, try destroying the system VMs after
changing the setting.

Cheers,
Darrin

________________________________
From: Andy Nguyen <andy.cator@anaki.net>
Sent: Monday, July 19, 2021 4:55 AM
To: users@cloudstack.apache.org <users@cloudstack.apache.org>
Subject: Re: Secondary storage doesn't work

First off, sorry for the dup post. 2nd, sorry for the late reply, and 3rd, my apologies for
being such an idiot. I found that I missed the system VM template step completely in all the
times I go through the steps.

That said, I got the system VM up, and now getting different error, that it can't find the
server. I checked the log, it says it can't resolve the server name I provided, which is odd.
I made sure the name resolves through the DNS, I also made the entry in host file on the management
VM, host machine, and my own. There's no problem resolving the name from CLI. The only place
I haven't done anything is the system VM that's created from template, but logically it should
just pull from DNS on the network, right?

On 2021/07/14 11:16:46, Darrin Hüsselmann <Darrin.Husselmann@shapeblue.com> wrote:
> Hi Andy,
>
> I agree with Ed.
>
> The error you are receiving means the Secondary Storage System VM has not started and
is not in the correct state to download the iso.
>
> Cloudstack needs to start two System VMs for it to be operational, Console Proxy VM and
Secondary Storage VM. But before it can do that, it needs a template to build the VMs from.
>
> You must execute the script from the management server that will upload the correct system
VM template to your secondary storage first before the SSVM and CPVM can be started. Only
then will you be able to register an iso.
>
> https://docs.cloudstack.apache.org/en/latest/installguide/management-server/index.html#prepare-the-system-vm-template
>
> You can find the Cloudstack logs under
>
> /var/log/cloudstack/
>
> Regards
> Darrin
> ________________________________
> From: Edward St Pierre <edward.stpierre@gmail.com>
> Sent: Wednesday, July 14, 2021 12:38 PM
> To: users@cloudstack.apache.org <users@cloudstack.apache.org>
> Subject: Re: Secondary storage doesn't work
>
> Hi Andy,
>
> Have you prepared the system VM template?
>
> Ed
>
>
>
>

 

> On Wed, 14 Jul 2021 at 11:32, Andy Nguyen <andy.cator@anaki.net> wrote:
>
> > Short version: identical nfs export for primary and secondary. Primary
> > works fine, secondary mounts but doesn't write.
> >
> > Long version:
> > I asked this on reddit
> > https://www.reddit.com/r/cloudstack/comments/o8rbsb/secondary_storage_help_please/
> > but didn't get much light on the matter.
> > Hypervisor host: Alma Linux + QEMU KVM + Cloudstack Agent + nfsd
> > Start a VM, also run Alma Linux + Cloudstack Management.
> >
> > Mount both primary and secondary via the web interface, that completed
> > without error.
> > Went and add ISO and I got "Request Failed (530) There is no secondary
> > storage VM for downloading template to image store Secondary"
> >
> > I can manually mount the NFS shares and read/write to it from inside the
> > VM without problem, so it's clearly not NFS nor permission problem.
> >
> > Any help on where I may start with troubleshooting? What log should I be
> > looking at?
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message