cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daan Hoogland <daan.hoogl...@gmail.com>
Subject Re: Problem with secondary storage
Date Fri, 16 Jul 2021 09:46:09 GMT
never mind this, I saw the answers on users@ and those will bring you
closer to a solution.

On Fri, Jul 16, 2021 at 11:44 AM Daan Hoogland <daan.hoogland@gmail.com>
wrote:

> Andy,
> Alma linux is not officially supported as a hypervisor host. That doesn't
> mean it shouldn't work but there are a lot of components it may fail on.
> Can you manually mount the secondary storage with the command line tools
> and find out what options you need? These might be different from what
> cloadstack uses internally.
> I don't think the qemu version has anything to do with it in this case but
> can you give the version of that anyway?
>
> regards,
>
> On Wed, Jul 14, 2021 at 7:37 AM Andy Nguyen <andy.cator@anaki.net> wrote:
>
>> Short version: identical nfs export for primary and secondary. Primary
>> works fine, secondary mounts but doesn't write.
>>
>> Long version:
>> I asked this on reddit
>>
>> https://www.reddit.com/r/cloudstack/comments/o8rbsb/secondary_storage_help_please/
>> but didn't get much light on the matter.
>> Hypervisor host: Alma Linux + QEMU KVM + Cloudstack Agent + nfsd
>> Start a VM, also run Alma Linux + Cloudstack Management.
>>
>> Mount both primary and secondary via the web interface, that completed
>> without error.
>> Went and add ISO and I got "Request Failed (530) There is no secondary
>> storage VM for downloading template to image store Secondary"
>>
>> I can manually mount the NFS shares and read/write to it from inside the
>> VM
>> without problem, so it's clearly not NFS nor permission problem.
>>
>> Any help on where I may start with troubleshooting? What log should I be
>> looking at?
>>
>
>
> --
> Daan
>


-- 
Daan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message