cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Piotr Pisz" <pi...@piszki.pl>
Subject RE: For input string: "9,17"
Date Thu, 05 Aug 2021 06:37:56 GMT
Hello,

I guess it's not the locale's fault. I run the test environment on CentOS 8 and 4.15.1, this
error appeared when I was using mysql-8-wsrep and galera-4, when I changed the DB to Mysql
8 (native with CentOS 8) the problem did not appear. In both cases, the locals in Mysql were
set to en_US.
I also checked what Daan wrote about, the problem occurred in both cases when the locals were
set to pl_PL and en_US.

I'm guessing this is something deeper in 4.15.1

But I have a question, why the CentOS 8 packages force you to install mysql-8 dependencies?
On other systems it doesn't. We have been using the mariadb-galera cluster for a long time
and forcing mysql-8 is a big problem.

Piotr


-----Original Message-----
From: James Steele <jsteele.email@gmail.com> 
Sent: Wednesday, August 4, 2021 12:30 PM
To: users@cloudstack.apache.org
Subject: Re: For input string: "9,17"

Could someone using Ubuntu 20.04, and the 4.15.1.0 webui - who can click on 'Infrastructure'
then 'Hosts' without errors and have it list correctly, please post the output of:

locale -v

It would nice to know a working input locale, and whether UTF or ISO-8859 is needed.

When I click 'Infrastructure' then 'Hosts' in the webui
(http://10.257.0.4:8080/client/) the error message: '(X) For input string: " 
"' is shown briefly.

The old client works fine (http://10.257.0.4:8080/client/legacy/).

Thanks!


Mime
View raw message