cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Cocoon 2.1.11 problem with JDK release versions above 255
Date Wed, 30 Jun 2021 17:58:10 GMT
Vincent,

On 6/30/21 11:24, Vincent Neyt wrote:
> Hi all,
> 
> thank you very much for all your reactions. I just found time to try 
> Nico Verwer's suggestion, and that worked perfectly! It seems it was the 
> very old version of icu4j.jar that caused the problem. As Nico suggested 
> I exchanged it for icu4j-69.1.jar in the lib directory, and was able to 
> start up cocoon without errors.

Glad you got things working.

I just wanted to reply to say that I'm running Tomcat Cocoon 2.1.11 on 
8.5.x on Java 8 and I have no issues.

openjdk version "1.8.0_292"
OpenJDK Runtime Environment (build 1.8.0_292-8u292-b10-0+deb9u1-b10)
OpenJDK 64-Bit Server VM (build 25.292-b10, mixed mode)

Hope that helps somewhat,
-chris

> On Wed, Jun 30, 2021 at 5:20 PM Cédric Damioli 
> <cedric.damioli@ametys.org <mailto:cedric.damioli@ametys.org>> wrote:
> 
>     Hi Vincent,
> 
>     Do you have any stack trace to help finding the actual issue ?
> 
>     I know there's a similar issue with the ICU library. Do you use it,
>     and if so in which version ?
> 
>     Regards,
>     Cédric
> 
> 
>     Le 30/06/2021 à 17:11, Francesco Chicchiriccò a écrit :
>>     On 28/06/21 09:48, Vincent Neyt wrote:
>>>     Hi list,
>>>
>>>     I did a stupid thing, I posted to the user list without first
>>>     subscribing, so I'm sending my query again now that I am
>>>     subscribed to the list. Sorry for the inconvenience!
>>>
>>>     Since 2011 I've been using a build of Cocoon 2.1.11 (inside
>>>     Tomcat 8) as the publishing framework for my website. I've
>>>     recently found out that Cocoon fails to start up when the
>>>     installed java version has an update number higher than 255.
>>>     Things start up properly with Java SE Development Kit 8u255 and
>>>     lower, but fail to start up with Java SE Development Kit 8u256
>>>     and higher (for instance the current Java SE Development Kit 8u291).
>>>
>>>     The error I get is
>>>
>>>     Initialization Problem: Scheduler with name 'Cocoon' already exists.
>>>
>>>     but it has cost me blood sweat and tears to find out that the
>>>     underlying cause is the Java update version number.
>>>
>>>     Is there a line in a file in my Cocoon 2.1.11 build that I could
>>>     change to get rid of this error?
>>
>>     Hi Vincent,
>>     I am afraid I cannot be of much help here, not using Cocoon 2.1
>>     since quite some time.
>>
>>     Anyway, did you find anything more than just the line reported
>>     above? Any stacktrace?
>>
>>     Regards.
>>
> 
>     -- 
>     <http://www.ametys.org>
>     <http://www.facebook.com/ametysCMS> <http://twitter.com/ametysCMS>
>     <http://plus.google.com/+ametysOrg/posts>
>     <http://www.youtube.com/user/ametysWebCMS>
> 
>     Cédric Damioli
> 
>     Directeur associé
> 
>     	+33 (0)5 62 19 19 07 / +33 (0)6 87 03 61 63     | +33 (0)5 61 75 84 12
>     cedric.damioli@ametys.org <mailto:cedric.damioli@ametys.org>
>     40 Rue du Village d'entreprises 31670 Labège
>     Inscrivez-vous à notre newsletter
>     <http://anyware-services.us2.list-manage2.com/subscribe?u=1cf1cbf2891b613e90fd95eb2&id=01c7bdfce3>
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message