Hi list,

I did a stupid thing, I posted to the user list without first subscribing, so I'm sending my query again now that I am subscribed to the list. Sorry for the inconvenience!

Since 2011 I've been using a build of Cocoon 2.1.11 (inside Tomcat 8) as the publishing framework for my website. I've recently found out that Cocoon fails to start up when the installed java version has an update number higher than 255. Things start up properly with Java SE Development Kit 8u255 and lower, but fail to start up with Java SE Development Kit 8u256 and higher (for instance the current Java SE Development Kit 8u291).

The error I get is 

Initialization Problem: Scheduler with name 'Cocoon' already exists.

but it has cost me blood sweat and tears to find out that the underlying cause is the Java update version number.

Is there a line in a file in my Cocoon 2.1.11 build that I could change to get rid of this error?

Thanks very much in advance!

Vincent Neyt