commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <>
Subject [jira] Commented: (LANG-420) Rename ObjectUtils.toString() to asString().
Date Mon, 09 Jun 2008 07:09:45 GMT


Henri Yandell commented on LANG-420:

Yep, I can confirm. Also will be a problem in ArrayUtils, BooleanUtils, ReflectionToStringBuilder,

equals(..) will be a problem in ObjectUtils and StringUtils. 

hashCode(..) will be a problem in ArrayUtils and ObjectUtils.

getClass(..) will be a problem in ClassUtils.

clone(..) will be a problem in ArrayUtils and SerializationUtils.

Work around - use the full invocation, ie: ObjectUtils.toString(...). I'm not sure we'll want
to go renaming all of the above.

> Rename ObjectUtils.toString() to asString().
> --------------------------------------------
>                 Key: LANG-420
>                 URL:
>             Project: Commons Lang
>          Issue Type: Improvement
>    Affects Versions: 2.3
>            Reporter: Stephen Kestle
>            Priority: Trivial
>             Fix For: LangTwo 1.0
>   Original Estimate: 0.5h
>  Remaining Estimate: 0.5h
> With Java 5 static method inlining, methods do not require class qualifying *unless*
the class already has the method.
> For this reason, ObjectUtlis.toString() cannot be inlined to toString(), as Object has
a toString() method.  
> It would be nice for it to have a name that could be statically imported, such as asString.
 This would follow the naming convention of Arrays.asList()
> Note that this DOES NOT need a java 5 version of lang.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message