commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <>
Subject [jira] Commented: (LANG-420) Rename ObjectUtils.toString() to asString().
Date Tue, 10 Jun 2008 05:31:46 GMT


Henri Yandell commented on LANG-420:

Or it could be reported as a bug to Sun. 

I'm not a fan of the static importing feature, so I definitely don't have the itch to go rename
things. I guess if we make _equals() methods or some such, a standard 'get around the problem'
approach instead of trying to rename every method, then it might be pretty easy.

> Rename ObjectUtils.toString() to asString().
> --------------------------------------------
>                 Key: LANG-420
>                 URL:
>             Project: Commons Lang
>          Issue Type: Improvement
>    Affects Versions: 2.3
>            Reporter: Stephen Kestle
>            Priority: Trivial
>             Fix For: LangTwo 1.0
> With Java 5 static method inlining, methods do not require class qualifying *unless*
the class already has the method.
> For this reason, ObjectUtlis.toString() cannot be inlined to toString(), as Object has
a toString() method.  
> It would be nice for it to have a name that could be statically imported, such as asString.
 This would follow the naming convention of Arrays.asList()
> Note that this DOES NOT need a java 5 version of lang.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message