Thank you for reply
I found a part of problem.
1-SELECT field1, field2 FROM APP.table2
the above statement will never works , i tried to execute it and it return no table found.
but the followiing statement works OK .
2-select * from "APP"."table2"
as i test them in netbeans IDE  SQL designer  , now i do not know how i can have something like 2 as an String variable to pass it to sql Statement or preparedStatement.
can some one help me about it ?

On 11/6/05, Michael Segel <> wrote:
On Saturday 05 November 2005 17:04, Legolas Woodland wrote:
> hi
> Thank you for reading my post.
> i tried to execute following statement but it return the exception that the
> table does not exists ,
> i tried several cobination of " and ' around the schema and table name with
> no luck.
>   "INSERT INTO APP.table2 ( data, data2 ) VALUES ( ?, ? )"
>   This statement return
>   Table 'APP.TABLE2' does not exist.
>  can some one help me ?
>  is there any way to pass schema name in connection url ? or set the schema
> to a default one?

Well, you have SET SCHEMA (see page 38 of Ref Manual)

Of course you may want to query your sysscheamas table to see the schema names
and also check to see that the table does exist in the schema that you think
it exists in...


Michael Segel