db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Cecchet <m...@frogthinker.org>
Subject Re: DatabaseMetaData.getTables() resultset empty?
Date Mon, 10 Nov 2008 03:47:00 GMT

It might be that Derby does not like it when the types are set to null.
In Sequoia, I use something like that and it works:
        String[] types = {"TABLE", "VIEW"};
        rs = connectionMetaData.getTables(null, null, "%", types);

Let me know if that works for you,

> I'm trying to use DatabaseMetaData.getTables() to get a list of tables 
> contained in a derby database.  I run the statement like this (I made 
> sure tables are present by browsing using the eclipse Data Source 
> explorer first):
> ResultSet resultSet = metaData.getTables(null, null, "%", null);
> But resultSet is empty.  I also tried it like this:
> ResultSet resultSet = metaData.getTables(null, null, 
> Still no love.  Anyone have any ideas on what I could be doing better? 
> Thanks,
> - Ole
Emmanuel Cecchet
FTO @ Frog Thinker 
Open Source Development & Consulting
Web: http://www.frogthinker.org
email: manu@frogthinker.org
Skype: emmanuel_cecchet

View raw message