db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject Re: Broken DB?
Date Thu, 06 Sep 2012 17:58:29 GMT
On 9/6/12 7:36 AM, Filip Zimandl wrote:
> Hi Rick,
> Thanks for your fast reply. I attached the log file (but without exact 
> source code location- why? can I fix it?- perhaps by compilation it 
> myself). Please see the attached screenshot where you can see URL I 
> use from both client versions. Also I'm able to connect different -not 
> corrupted- database as seen there too.
> Cheers,
> Filip
> On 6.9.2012 13:10, Rick Hillegas wrote:
>> On 9/6/12 3:16 AM, Filip Zimandl wrote:
>>> Hi there,
>>> I have a problem to accessing Derby DB with ij client. The DB files 
>>> might be broken somehow. It was originally accessed by 
>>> version from an application. I tried to access it with current 
>>> but it gives an error. Subsequently I tried to access it 
>>> with but also without success. It gives ERROR XSLAC: 
>>> database has incompatible format and could be created by a later 
>>> version. OK, but I have the latest version installed. What is wrong? 
>>> Is it there a mechanism/tool how can I restore my data?
>>> Thanks for pointing me in the right direction.
>>> Filip
>> Hi  Filip,
>> Can you share the following information:
>> 1) The connection URL you used to connect to the database using 10.9.1.
>> 2) The connection URL you used to connect to the database using 10.8.1.
>> 3) The stack traces (from derby.log) which accompanied the failed 
>> connection attempts.
>> Thanks,
>> -Rick
Hi Filip,

Thanks for attaching the log file. The triggering SQLState is XSLAC 
(Database at {0} has a format incompatible with the current version of 
software. It may have been created by or upgraded by a later version.). 
The wording of that error message appears to me to be misleading. I'm 
not aware of a change to the log file format introduced by 10.9. This 
looks like a corruption of the log file to me.

Does anyone have more specific experience with this error?


View raw message