db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oskar Zinger <oska...@yahoo.com>
Subject Re: Upgrade from to
Date Wed, 06 Nov 2013 19:19:15 GMT
Hi Mike,

I'm doing a "soft" upgrade, by just updating the jars.

I tried to start the Derby DB stand alone on both servers and they did start just fine. I
was also able to cleanly shutdown both.

But as soon as I start the replication process, it fails because the databases are out of


On Wednesday, November 6, 2013 1:15 PM, mike matrigali <mikemapp1@gmail.com> wrote:
I also don't know much about replication, so apologize if the following
does not make sense.  Have you tried "decoupling" the replication,
do the upgrade and then reestablishing the replication making sure
the latest software is on all systems.

Also for a problem report it may help to state what "Upgrade" means
to you.  For instance the following:
o I just updated jars everywhere
o I want to run in "soft" upgrade mode everywhere after updating jars
o I want to hard upgrade master.

Not sure if it will help with not being able to upgrade in general, but
may help to understand the problem.  And as Kathey mentioned filing
a JIRA with a reproducible test case is likely the best way to get help.
Unfortunately the community members that implemented replication are not
active, and the expertise on the feature is limited in the community.


On 11/5/2013 9:32 AM, Oskar Zinger wrote:
> Hi Kathey,
> Nope that does not seem to help.
> Thanks,
> Oskar
> On Tuesday, November 5, 2013 11:54 AM, Katherine Marsden
> <kmarsdenderby@sbcglobal.net> wrote:
> On 11/5/2013 8:46 AM, Oskar Zinger wrote:
>> Hello,
>> I'm in the process of upgrading to
>> Once I did the upgrade, the Derby replication no longer works. It now
>> complains about the Databases being not in synch.
>> This same code was working just fine in, but does not work in
>> Anyone experienced this?
>> This is the error I'm getting:
>> java.sql.SQLNonTransientConnectionException: DERBY SQL error:
>> ERRORCODE: 40000, SQLSTATE: XRE05, SQLERRMC: The log files on the
>> master and slave are not in synch for replicated database 'ImpactDB'.
>> The master log instant is 1:980936, whereas the slave log instant is
>> 1:846980. This is fatal for replication - replication will be stopped.
> I am not familiar with replication, but wonder if it is a requirement of
> upgrade to do a clean shutdown of the database before upgrading the jars
> or if that would at least help you work around the problem.  I couldn't
> find anything in the documentation though requiring special procedures
> for upgrade with replication.
> Kathey
View raw message