directory-api mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lucas Raab" <tuftedoce...@fastmail.fm>
Subject Re: NPE doing schema-aware AD searches in LDAP API 2.0
Date Tue, 11 Feb 2020 10:55:58 GMT
On Tue, Feb 11, 2020, at 02:42, Emmanuel Lécharny wrote:
> Hi
> 
> On 11/02/2020 01:17, Lucas Raab wrote:
> > On Mon, Feb 10, 2020, at 17:37, Emmanuel Lécharny wrote:
> >> Hi !
> >>
> >>
> >>    Can you provide the stack trace, and the entry you are trying to read ?
> >>
> >> I'm interested to know on which attribute it fails.
> >>
> >>
> >> Thanks !
> >>
> >> On 10/02/2020 22:36, Lucas Raab wrote:
> >>> This time with attachments :)
> >>>
> >>> On Mon, Feb 10, 2020 at 03:32:36PM -0600, Lucas Raab wrote:
> >>>> Hello,
> >>>>
> >>>> I'm getting NPE's while attempting to read from a fresh AD install with
> >>>> a 2012R2 level domain. If I don't load the schema (relaxed or strict),
> >>>> the search runs normally. if I do load the schema, then the search
> >>>> throws the NPE. No error is thrown when I attempted similar searches
> >>>> against an OpenDJ 6.5 server.
> >>>>
> >>>> It appears to come from attempting to determine if an LdapSyntax from
> >>>> an AttributeType is human readable or not. The LdapSyntax object looks
> >>>> to be null, but is visible when dumping the AttributeType. I'm not
> >>>> entirely sure where the schema-aware attribute loading is happening
to
> >>>> try and fix it myself so here I am :)
> >>>>
> >>>> Attached is a log and sample source file. I can provide credentials
in
> >>>> a private mail for any debugging.
> >>>>
> >>>> Thanks,
> >>>> Lucas
> >>>>
> >>>> ---------------------------------------------------------------------
> >>>> To unsubscribe, e-mail: api-unsubscribe@directory.apache.org
> >>>> For additional commands, e-mail: api-help@directory.apache.org
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: api-unsubscribe@directory.apache.org
> >> For additional commands, e-mail: api-help@directory.apache.org
> >>
> >>
> > Hm, the log I attached seems to have been dropped...
> >
> > Here's the stack trace and let me know if you need/want more
> >
> > 2020-02-10 15:16:24,027 DEBUG - Attribute: cn: Test Bind
> > 2020-02-10 15:16:24,027 DEBUG - Attribute: cn: Test Bind
> > 2020-02-10 15:16:24,027 WARN  -
> > java.lang.NullPointerException
> >    at org.apache.directory.api.ldap.model.entry.DefaultAttribute.<init>(DefaultAttribute.java:424)
> >    at org.apache.directory.api.ldap.model.entry.DefaultEntry.<init>(DefaultEntry.java:324)
> 
> 
> Hmmm, it seems to be older revision than the last one. 
> DefaultAttribute.java:424 refers to a comment in the 2.0 revision.
> 
> 
> Can you check which LDAP API revision you are using ?
> 
> Thanks !
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: api-unsubscribe@directory.apache.org
> For additional commands, e-mail: api-help@directory.apache.org
> 
>

Hi Emmanuel,

I'm using LDAP API 2.0.0 retrieved via Maven if that matters.

Thanks for your time looking at this!

Lucas

---------------------------------------------------------------------
To unsubscribe, e-mail: api-unsubscribe@directory.apache.org
For additional commands, e-mail: api-help@directory.apache.org


Mime
View raw message