directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fortunato Margariti (JIRA)" <>
Subject [jira] [Commented] (DIRSERVER-1979) Adding subentries after restarting server, aren't found.
Date Tue, 10 Jun 2014 09:53:01 GMT


Fortunato Margariti commented on DIRSERVER-1979:

Yes of course. To fast my test i'm using the quick search panel of apache directory studio
now, but i have the same result using java spring ldaptemplate. The search request in the
quick search of directory studio has the following parameter:
1) Search base: ou=groups,dc=xxx,dc=com 
2) filter: (objectClass=*)
3) returning attributes: empty
4)Controls: no flags (i've tried also to flag subentries but no object are founded with the
5)Scope:   subtree
6) Aliases Dereferencing: default values
7) Referrals Handling: default values

> Adding subentries after restarting server, aren't found.
> --------------------------------------------------------
>                 Key: DIRSERVER-1979
>                 URL:
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: ldap
>    Affects Versions: 2.0.0-M16, 2.0.0-M17
>         Environment: windows seven.
>            Reporter: Fortunato Margariti
> Suppose to have the following situation on the Server (created with ldif):
> dc=xxx,dc=com
> ........ou=groups
> .............. cn=aim
> .............. cn=ais
> .................... cn=aisOperator
> .............. cn=admin
> If you stop and restart the server and then create a subentry (named for example "child")
under any leaf on the tree (in this case under "aim" or "aisOperator" or "admin"), happen
the following:
> 1) the new entry is not visible with a search that start
>  from ou=groups,dc=xxx,dc=com 
> 2) the new entry is visible only if the search start from dc=xxx,dc=com
>    or starting from the leaf: ou=aim,ou=groups,dc=xxx,dc=com
> 3) If you perform an ldif export on ou=groups,dc=xxx,dc=com, you can't find the new added
> 4) if the subentry is created under cn=ais (that is not a leaf because has already a
subentry) the new "child" entry is founded by the search
> I was thinking that the problem was related to DIRSERVER-1976 (solved on M17) but we
have the same problems also on this version.

This message was sent by Atlassian JIRA

View raw message