directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <>
Subject [jira] [Commented] (DIRSERVER-1990) Lock file named incorrectly on CentOS (& possibly others?)
Date Sun, 03 Aug 2014 14:21:11 GMT


Emmanuel Lecharny commented on DIRSERVER-1990:

You should be able to start the server passing the name of teh ianstance you want it to use.
If you don't, the script uses 'default'.

As you may have more than one server running on a machine, it makes no sense to provide a
fixed value for this parameter.

> Lock file named incorrectly on CentOS (& possibly others?)
> ----------------------------------------------------------
>                 Key: DIRSERVER-1990
>                 URL:
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M16
>         Environment: CentOS 6.5
>            Reporter: Brad Trantham
>            Priority: Minor
> I was having trouble configuring my ApacheDS installation to auto-start when the server
boots. During boot it would log an error saying that the default instance was already running
but there was no ApacheDS process running and I was unable to connect to the LDAP instance.

> ApacheDS would start/stop with no problem when I ran it manually but it seemed like it
wouldn't shut down cleanly during server shutdown, it was leaving the pid file in place which
was preventing it from retstarting upon boot. 
> After digging into various searches online I uncovered a suggestion that CentOS would
not kill a process if the lock file was named something other than what the shutdown script
in rc6.d was named. This was the case for me, the rc6.d script was called K35apacheds-2.0.0_M16-default
but the lock file under /var/lock/subsys was simply called default.
> I fixed this for my installation by changing line 144 of /opt/apacheds-2.0.0_M16/bin/apachds
> to
> LOCKFILE="$LOCKDIR/apacheds-2.0.0_M16-default"
> Obviously the real fix should be a bit cleaner than that but it worked and now my ApacheDS
installation shuts down cleanly when the server is restarted and reliably starts up upon boot.

This message was sent by Atlassian JIRA

View raw message