drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Rogers (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DRILL-5276) Upgrade Typesafe library from 1.0.0 to latest 1.3.1
Date Mon, 20 Feb 2017 00:51:44 GMT
Paul Rogers created DRILL-5276:
----------------------------------

             Summary: Upgrade Typesafe library from 1.0.0 to latest 1.3.1
                 Key: DRILL-5276
                 URL: https://issues.apache.org/jira/browse/DRILL-5276
             Project: Apache Drill
          Issue Type: Improvement
    Affects Versions: 1.10.0
            Reporter: Paul Rogers
            Priority: Minor


Drill uses the old, original version of the Typesafe config library. Drill should attempt
to stay up to date with libraries. The latest Typesafe version is 1.3.1. The latest version
provides a way to set the value of list parameters using Properties, something not possible
in version 1.0.0. As a result, using the new test framework, it is not possible to set list
properties such as the list of spill directories.

This change should be made early in a release to give plenty of time to test.

The major impact is that DrillConfig must implement a bunch of new methods. This may reflect
other changes in the structure of the library that we must handle.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message