drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arina Yelchiyeva <arina.yelchiy...@gmail.com>
Subject Re: Contrib Plugin Question
Date Mon, 03 Sep 2018 19:35:41 GMT
Personally, I did not have such problems with IntelliJ, did not try Eclipse, so can’t tell.
Maybe somebody else can chime in.

Kind regards,

> On Sep 3, 2018, at 10:23 PM, Paul Rogers <par0328@yahoo.com.INVALID> wrote:
> I've been helping Charles with this. He's got a branch that works some times, but not
> * If I run his unit test from Eclipse, it works.
> * If I run his unit test from the command line with Maven, it works.
> * If he runs his unit test using the mechanism he is using, Drill can't find his class.
> The question is, has anyone who uses IntelliJ run into a similar issue? Do you recall
what you had to fix?
> I'll continue to work with Charles to figure out what, exactly, he is doing to run the
test to see if we can zero in on the problem. But would be great if someone said, "Yeah, I
had that issue and I had to ..."
> Thanks,
> - Paul
>    On Monday, September 3, 2018, 7:40:18 AM PDT, Arina Yelchiyeva <arina.yelchiyeva@gmail.com>
> Hi Charles.
> Recently new udfs module was added under contrib, you can can take look at
> that PR for the example.
> Regarding unit tests and data availability:
> 1. create TEST resources folder where you'll copy your data.
> 2. use dirTestWatcher to copy data to the root / tmp / custom directory.
> 3. query the data:
> @Test
> public void t() {
>   dirTestWatcher.copyResourceToRoot(Paths.get("complex_1.parquet"));
>   queryBuilder().sql("select * from dfs.`root`.`complex_1.parquet`").printCsv();
> }
> Also I would suggest you create module formats under contrib and place your
> format plugin module under formats: contrib / formats / format-plugin.
>> On Mon, Sep 3, 2018 at 4:38 PM Charles Givre <cgivre@gmail.com> wrote:
>> Hello all,
>> I’m working on a format-plugin for syslog (RFC-5424) data and I’m having
>> some strange issues.  I’d like to submit this contribution in the contrib/
>> folder, however I cannot seem to get Drill to recognize the module.  I’ve
>> built the module separately, and the code works, however, when I try to
>> build Drill, it does not recognize the module and I cannot query my data
>> (and the unit tests fail).  I’ve added the module to the contrib pom.xml
>> file and added the module to the assemble/bin.xml and still no luck.
>> Here’s the REALLY weird part.  I can run the unit tests in IntelliJ and it
>> works but it does not if I run the tests from the command line.
>> The code can be found here:
>> https://github.com/cgivre/drill/tree/format-syslog <
>> https://github.com/cgivre/drill/tree/format-syslog>
>> Does anyone have any suggestions?
>> —C

View raw message